aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-06-26 07:06:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-06-26 07:06:14 +0000
commitdbc51aae257c210089df3bbc7d65600c5abc95ff (patch)
tree9e7b18c113c4bead0a2a4bc443f0a2db8f10d407 /security/hpn-ssh/Makefile
parent1ae078dcd52c484085ffa55162ff974d16a07449 (diff)
downloadports-dbc51aae257c210089df3bbc7d65600c5abc95ff.tar.gz
ports-dbc51aae257c210089df3bbc7d65600c5abc95ff.zip
Notes
Diffstat (limited to 'security/hpn-ssh/Makefile')
-rw-r--r--security/hpn-ssh/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 9ba5fd1725e4..a37a28004dc5 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -50,6 +50,7 @@ MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man --localstatedir=/var
EMPTYDIR= /var/empty
ETCSSH= /etc/ssh
+PLIST_SUB+= NOTBASE="@comment "
.else
.if exists(/var/empty)
EMPTYDIR= /var/empty
@@ -57,6 +58,7 @@ EMPTYDIR= /var/empty
EMPTYDIR= ${PREFIX}/empty
.endif
ETCSSH= ${PREFIX}/etc/ssh
+PLIST_SUB+= NOTBASE=""
.endif
PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
@@ -108,7 +110,9 @@ pre-install:
.endfor
post-install:
+.if defined(OPENSSH_OVERWRITE_BASE)
${INSTALL_SCRIPT} ${WRKSRC}/sshd.sh ${PREFIX}/etc/rc.d/sshd.sh.sample
+.endif
${INSTALL_DATA} -c ${WRKSRC}/ssh_config.out ${ETCSSH}/ssh_config-dist
${INSTALL_DATA} -c ${WRKSRC}/sshd_config.out ${ETCSSH}/sshd_config-dist
@${CAT} ${PKGMESSAGE}