aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-06-24 23:04:37 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-06-24 23:04:37 +0000
commitdea8f0280a584edbef126d277ea5d89b0296166f (patch)
tree63e427cc49a0a5494ee40e38ff509b113425cfa2 /security/hpn-ssh
parent8318689db59b0c225704471ae4309e713ffab07a (diff)
Notes
Diffstat (limited to 'security/hpn-ssh')
-rw-r--r--security/hpn-ssh/Makefile8
-rw-r--r--security/hpn-ssh/pkg-plist1
2 files changed, 9 insertions, 0 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index bb678422843a..2640cf594d1c 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.3p1
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
@@ -23,6 +24,7 @@ MAN8= sftp-server.8 sshd.8 ssh-keysign.8
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-md5-passwords
+CONFIGURE_ARGS+= --with-privsep-path=${PREFIX}/empty
CLEAN= etc/ssh_config etc/sshd_config etc/moduli \
etc/ssh_host_key etc/ssh_host_key.pub \
etc/ssh_host_dsa_key etc/ssh_host_dsa_key.pub \
@@ -78,6 +80,12 @@ pre-configure:
(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
.endif
+pre-install:
+ if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
+ if ! pw usershow sshd; then pw useradd sshd -g sshd -u 22 \
+ -h - -d ${PREFIX}/empty -s /nonexistent -c "sshd privilege separation"; fi
+ ${MKDIR} ${PREFIX}/empty
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/security/hpn-ssh/pkg-plist b/security/hpn-ssh/pkg-plist
index 4e3df800e8c9..4c71fad37b75 100644
--- a/security/hpn-ssh/pkg-plist
+++ b/security/hpn-ssh/pkg-plist
@@ -11,3 +11,4 @@ sbin/sshd
share/Ssh.bin
libexec/sftp-server
libexec/ssh-keysign
+@dirrm empty