aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-03-08 05:54:04 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-03-08 05:54:04 +0000
commite95e5c70ff26973e0d0a0bc54618f223f1e64867 (patch)
tree76b22f2968987e7f6074a17d60a4c47fb01b2ff5 /security/hpn-ssh
parent5ac4aadbfa2937f38ebd915ff654dbb18b6c17d4 (diff)
Notes
Diffstat (limited to 'security/hpn-ssh')
-rw-r--r--security/hpn-ssh/Makefile3
-rw-r--r--security/hpn-ssh/distinfo4
-rw-r--r--security/hpn-ssh/files/patch-channels.c11
-rw-r--r--security/hpn-ssh/files/patch-session.c33
4 files changed, 20 insertions, 31 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 0412868bda3d..e5b517170347 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openssh
-PORTVERSION= 3.0.2p1
-PORTREVISION= 1
+PORTVERSION= 3.1p1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
diff --git a/security/hpn-ssh/distinfo b/security/hpn-ssh/distinfo
index 4f636c0ddd6d..ae7285957283 100644
--- a/security/hpn-ssh/distinfo
+++ b/security/hpn-ssh/distinfo
@@ -1,3 +1 @@
-MD5 (openssh-3.0.2p1.tar.gz) = 2fa62bf878862cb47a7515c35afe35b6
-MD5 (openssh-3.0.2p1-gssapi.patch) = 66ce171ac4b09603c7069cea198d2090
-MD5 (openssh-3.0.2p1-krb5.patch) = c6fe5622607b3137fa22741897cbd5db
+MD5 (openssh-3.1p1.tar.gz) = c6a52d4126ed27eb57c31729ec6b2362
diff --git a/security/hpn-ssh/files/patch-channels.c b/security/hpn-ssh/files/patch-channels.c
deleted file mode 100644
index fc11fc9c6bad..000000000000
--- a/security/hpn-ssh/files/patch-channels.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- channels.c.orig Wed Oct 10 17:18:47 2001
-+++ channels.c Wed Mar 6 07:49:46 2002
-@@ -145,7 +145,7 @@
- {
- Channel *c;
-
-- if (id < 0 || id > channels_alloc) {
-+ if (id < 0 || id >= channels_alloc) {
- log("channel_lookup: %d: bad id", id);
- return NULL;
- }
diff --git a/security/hpn-ssh/files/patch-session.c b/security/hpn-ssh/files/patch-session.c
index 28dc7a851ec3..211addbf8b13 100644
--- a/security/hpn-ssh/files/patch-session.c
+++ b/security/hpn-ssh/files/patch-session.c
@@ -1,6 +1,6 @@
---- session.c.orig Mon Sep 17 00:17:15 2001
-+++ session.c Wed Oct 3 14:18:36 2001
-@@ -437,6 +437,13 @@
+--- session.c.orig Mon Feb 25 16:48:03 2002
++++ session.c Fri Mar 8 06:28:38 2002
+@@ -423,6 +423,13 @@
log_init(__progname, options.log_level, options.log_facility, log_stderr);
/*
@@ -14,7 +14,7 @@
* Create a new session and process group since the 4.4BSD
* setlogin() affects the entire process group.
*/
-@@ -551,6 +558,14 @@
+@@ -537,6 +544,14 @@
/* Child. Reinitialize the log because the pid has changed. */
log_init(__progname, options.log_level, options.log_facility, log_stderr);
@@ -29,7 +29,7 @@
/* Close the master side of the pseudo tty. */
close(ptyfd);
-@@ -682,6 +697,11 @@
+@@ -665,6 +680,11 @@
time_t last_login_time;
struct passwd * pw = s->pw;
pid_t pid = getpid();
@@ -41,7 +41,7 @@
/*
* Get IP address of client. If the connection is not a socket, let
-@@ -742,6 +762,21 @@
+@@ -725,6 +745,21 @@
printf("Last login: %s from %s\r\n", time_string, hostname);
}
@@ -63,7 +63,7 @@
do_motd();
}
-@@ -1340,7 +1375,7 @@
+@@ -1241,7 +1276,7 @@
* initgroups, because at least on Solaris 2.3 it leaves file
* descriptors open.
*/
@@ -71,12 +71,14 @@
+ for (i = 3; i < getdtablesize(); i++)
close(i);
- /* Change current directory to the user\'s home directory. */
-@@ -1376,6 +1411,28 @@
- * in this order).
- */
- if (!options.use_login) {
+ /*
+@@ -1271,6 +1306,31 @@
+ exit(1);
+ #endif
+ }
++
+#ifdef __FreeBSD__
++ if (!options.use_login) {
+ /*
+ * If the password change time is set and has passed, give the
+ * user a password expiry notice and chance to change it.
@@ -97,7 +99,8 @@
+ }
+ }
+ }
++ }
+#endif /* __FreeBSD__ */
- /* ignore _PATH_SSH_USER_RC for subsystems */
- if (!s->is_subsystem && (stat(_PATH_SSH_USER_RC, &st) >= 0)) {
- snprintf(cmd, sizeof cmd, "%s -c '%s %s'",
+
+ if (!options.use_login)
+ do_rc_files(s, shell);