aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-12-01 20:25:47 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-12-01 20:25:47 +0000
commitf3b66a5fccdb771d724540a164f43c4cdd2e1713 (patch)
tree8a1e2622639a67d7109fa25c344f15caa77d4185 /security/hpn-ssh
parentb48bb8050b0271952545a85d918b7b27f87f8014 (diff)
downloadports-f3b66a5fccdb771d724540a164f43c4cdd2e1713.tar.gz
ports-f3b66a5fccdb771d724540a164f43c4cdd2e1713.zip
Notes
Diffstat (limited to 'security/hpn-ssh')
-rw-r--r--security/hpn-ssh/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index b4672929a9a4..6d93acb48218 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
PKGNAMESUFFIX= -portable
-MAINTAINER= dinoex@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
MAN1= sftp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 scp.1 ssh.1
MLINKS= ssh.1 slogin.1
@@ -23,6 +23,10 @@ CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
USE_OPENSSL= YES
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --prefix=${PREFIX} --with-md5-passwords
+CLEAN= etc/ssh_config etc/sshd_config etc/moduli \
+ etc/ssh_host_key etc/ssh_host_key.pub \
+ etc/ssh_host_dsa_key etc/ssh_host_dsa_key.pub \
+ etc/ssh_host_rsa_key etc/ssh_host_rsa_key.pub
.if exists(/usr/include/security/pam_modules.h)
CONFIGURE_ARGS+= --with-pam
@@ -34,5 +38,8 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(BATCH)
+ @(cd ${PREFIX} && ${RM} -f ${CLEAN})
+.endif
.include <bsd.port.mk>