aboutsummaryrefslogtreecommitdiff
path: root/security/hs-Crypto
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-08-01 13:38:44 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-08-01 13:38:44 +0000
commit193cf6aad7f85324efd91ee877702aa9b218098b (patch)
treef1fa9f3f034f3f70d51b7f3014676f9da3b5d731 /security/hs-Crypto
parent32e41d327d1d72e3f3a09a68f566c3176afe8c1c (diff)
DES, Blowfish, AES, TEA, SHA1, MD5, RSA, BubbleBabble, Hexdump, Support for
Word128, Word192 and Word256 and Beyond, PKCS5 Padding, Various Encryption Modes e.g. Cipher Block Chaining all in one package, with HUnit and QuickCheck tests, and examples. WWW: http://hackage.haskell.org/package/Crypto Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=278707
Diffstat (limited to 'security/hs-Crypto')
-rw-r--r--security/hs-Crypto/Makefile24
-rw-r--r--security/hs-Crypto/distinfo2
-rw-r--r--security/hs-Crypto/pkg-descr6
3 files changed, 32 insertions, 0 deletions
diff --git a/security/hs-Crypto/Makefile b/security/hs-Crypto/Makefile
new file mode 100644
index 000000000000..945e335ee7d3
--- /dev/null
+++ b/security/hs-Crypto/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-Crypto
+# Date created: July 5, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypto
+PORTVERSION= 4.2.3
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Collects together existing Haskell cryptographic functions
+
+FILE_LICENSE= ReadMe.tex
+
+USE_CABAL= QuickCheck>=2.4.0.1 HUnit
+CABAL_SETUP= Setup.hs
+
+EXECUTABLE= HMACTest QuickTest RSATest SHA1Test SymmetricTest WordListTest
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-Crypto/distinfo b/security/hs-Crypto/distinfo
new file mode 100644
index 000000000000..563c233cc885
--- /dev/null
+++ b/security/hs-Crypto/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/Crypto-4.2.3.tar.gz) = 7909f4deae9478c234c717a7ff5bd6683ccbf6a199b28d6463281e113d45910b
+SIZE (cabal/Crypto-4.2.3.tar.gz) = 56913
diff --git a/security/hs-Crypto/pkg-descr b/security/hs-Crypto/pkg-descr
new file mode 100644
index 000000000000..55c7064eaa62
--- /dev/null
+++ b/security/hs-Crypto/pkg-descr
@@ -0,0 +1,6 @@
+DES, Blowfish, AES, TEA, SHA1, MD5, RSA, BubbleBabble, Hexdump, Support for
+Word128, Word192 and Word256 and Beyond, PKCS5 Padding, Various Encryption
+Modes e.g. Cipher Block Chaining all in one package, with HUnit and
+QuickCheck tests, and examples.
+
+WWW: http://hackage.haskell.org/package/Crypto