aboutsummaryrefslogtreecommitdiff
path: root/security/hs-cryptonite
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
committerGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
commit39b8e49140afdb1d1d001c477befb4b05efa7fc3 (patch)
tree607a5ca77efd301a2b4dc49b05d108829fcffa77 /security/hs-cryptonite
parent75b64b1cb42c127b71646f039269eb7bd560d8ef (diff)
downloadports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.tar.gz
ports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.zip
Notes
Diffstat (limited to 'security/hs-cryptonite')
-rw-r--r--security/hs-cryptonite/Makefile18
-rw-r--r--security/hs-cryptonite/distinfo2
-rw-r--r--security/hs-cryptonite/pkg-descr19
3 files changed, 39 insertions, 0 deletions
diff --git a/security/hs-cryptonite/Makefile b/security/hs-cryptonite/Makefile
new file mode 100644
index 000000000000..294bb155b2e2
--- /dev/null
+++ b/security/hs-cryptonite/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= cryptonite
+PORTVERSION= 0.6
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Cryptography Primitives sink
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= memory>=0.2
+
+FLAGS_ENABLE= support_aesni support_rdrand integer-gmp support_deepseq
+FLAGS_DISABLE= support_pclmuldq
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-cryptonite/distinfo b/security/hs-cryptonite/distinfo
new file mode 100644
index 000000000000..09f76b311552
--- /dev/null
+++ b/security/hs-cryptonite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cryptonite-0.6.tar.gz) = a016ccaa38579beb4517807a8917801baf6e6ddb830a74af91fc064c35acf853
+SIZE (cabal/cryptonite-0.6.tar.gz) = 319290
diff --git a/security/hs-cryptonite/pkg-descr b/security/hs-cryptonite/pkg-descr
new file mode 100644
index 000000000000..315c9e1ca248
--- /dev/null
+++ b/security/hs-cryptonite/pkg-descr
@@ -0,0 +1,19 @@
+A repository of cryptographic primitives.
+
+ * Symmetric ciphers: AES, DES, 3DES, Blowfish, Camellia, RC4, Salsa, ChaCha.
+ * Hash: SHA1, SHA2, SHA3, MD2, MD4, MD5, Kekkak, Skein, Ripemd, Tiger,
+ Whirlpool
+ * MAC: HMAC, Poly1305
+ * Assymmetric crypto: DSA, RSA, DH, ECDH, ECDSA, ECC, Curve25519, Ed25519
+ * Key Derivation Function: PBKDF2, Scrypt
+ * Cryptographic Random generation: System Entropy, Deterministic Random
+ Generator
+ * Data related: Anti-Forensic
+
+Information Splitter (AFIS) If anything cryptographic related is missing
+from here, submit a pull request to have it added. This package strive
+to be a cryptographic kitchen sink that provides cryptography for
+everyone. Evaluate the security related to your requirements before
+using.
+
+WWW: https://github.com/vincenthz/cryptonite