aboutsummaryrefslogtreecommitdiff
path: root/security/hs-tls/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-18 16:23:00 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-18 16:23:00 +0000
commit98c816c3bef38cc46597f3bc155d9f0dea5f8aa4 (patch)
treeccec8027f352ee10d9af7d238c1a6f0a0eafb650 /security/hs-tls/Makefile
parentb00b470facc8c032ab8ae9d13aa131a1017b16ba (diff)
downloadports-98c816c3bef38cc46597f3bc155d9f0dea5f8aa4.tar.gz
ports-98c816c3bef38cc46597f3bc155d9f0dea5f8aa4.zip
Notes
Diffstat (limited to 'security/hs-tls/Makefile')
-rw-r--r--security/hs-tls/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
new file mode 100644
index 000000000000..ee75beca0820
--- /dev/null
+++ b/security/hs-tls/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: hs-tls
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tls
+PORTVERSION= 0.8.5
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= TLS/SSL protocol native implementation (server and client)
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= cereal>=0.3 certificate>=1.0.0 crypto-api>=0.5 \
+ cryptocipher>=0.3.0 cryptohash>=0.6 mtl
+
+OPTIONS= EXECUTABLE "Build the executables" off
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_EXECUTABLE)
+CONFIGURE_ARGS+= --flags="executable"
+USE_CABAL+= cmdargs cprng-aes>=0.2.3 network
+EXECUTABLE+= stunnel checkciphers retrievecertificate simpleclient
+.else
+CONFIGURE_ARGS+= --flags="-executable"
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>