aboutsummaryrefslogtreecommitdiff
path: root/security/hs-x509-store
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /security/hs-x509-store
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
downloadports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.tar.gz
ports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.zip
Notes
Diffstat (limited to 'security/hs-x509-store')
-rw-r--r--security/hs-x509-store/Makefile16
-rw-r--r--security/hs-x509-store/distinfo2
-rw-r--r--security/hs-x509-store/pkg-descr4
3 files changed, 22 insertions, 0 deletions
diff --git a/security/hs-x509-store/Makefile b/security/hs-x509-store/Makefile
new file mode 100644
index 000000000000..f7511d372f79
--- /dev/null
+++ b/security/hs-x509-store/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= x509-store
+PORTVERSION= 1.4.4
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= X.509 collection accessing and storing methods
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= asn1-encoding>=0.8 asn1-types>=0.2 crypto-pubkey-types>=0.3 \
+ mtl pem>=0.1 x509>=1.4.3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-x509-store/distinfo b/security/hs-x509-store/distinfo
new file mode 100644
index 000000000000..4375898ce2c5
--- /dev/null
+++ b/security/hs-x509-store/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/x509-store-1.4.4.tar.gz) = 882fc144a6819dd9182e14297f3af9087c45840cca1c550e759783dc5a767044
+SIZE (cabal/x509-store-1.4.4.tar.gz) = 2992
diff --git a/security/hs-x509-store/pkg-descr b/security/hs-x509-store/pkg-descr
new file mode 100644
index 000000000000..0266c1e1b1a7
--- /dev/null
+++ b/security/hs-x509-store/pkg-descr
@@ -0,0 +1,4 @@
+X.509 collection accessing and storing methods for certificate, crl,
+exception list.
+
+WWW: http://github.com/vincenthz/hs-certificate