aboutsummaryrefslogtreecommitdiff
path: root/security/hydra/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-10-20 10:48:56 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-10-20 10:48:56 +0000
commita22130ad45b0ee1934ac254eb40c456f37712cf0 (patch)
tree75df06bc57ef6b299231193d8dc762703acc6fa1 /security/hydra/Makefile
parent03d4af3daf86817fb15a6dc0721ead6283762ace (diff)
Notes
Diffstat (limited to 'security/hydra/Makefile')
-rw-r--r--security/hydra/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index bf13da86ee54..a476e8088ba1 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -8,6 +8,7 @@
PORTNAME= hydra
PORTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/ \
${MASTER_SITE_PACKETSTORM}
@@ -16,17 +17,15 @@ MASTER_SITE_SUBDIR= groups/thc
MAINTAINER= llevier@argosnet.com
COMMENT= Bruce Force Attack Utility working on multiple network services
-.include <bsd.port.pre.mk>
-
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC = gcc||; \
+ s|-O2|${CFLAGS}|' \
+ ${WRKSRC}/Makefile.am
-.if !target(post-install) && (${PORTNAME} == "hydra")
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/hydra
-.endif
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/hydra ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>