aboutsummaryrefslogtreecommitdiff
path: root/security/hydra
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-28 17:35:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-28 17:35:46 +0000
commit9305904409fae6ce80a349ff90e8ec9efc7b4c06 (patch)
tree1a13af6412a5f1c1729164301ce1d6d48637e143 /security/hydra
parent2f73ea35eb6929ea88ea7c5af938a36796759a69 (diff)
downloadports-9305904409fae6ce80a349ff90e8ec9efc7b4c06.tar.gz
ports-9305904409fae6ce80a349ff90e8ec9efc7b4c06.zip
Notes
Diffstat (limited to 'security/hydra')
-rw-r--r--security/hydra/Makefile3
-rw-r--r--security/hydra/distinfo3
-rw-r--r--security/hydra/files/patch-hydra.c56
3 files changed, 3 insertions, 59 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index 0f9e4b45733d..d006184b2a36 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= hydra
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.6
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/ \
${MASTER_SITE_PACKETSTORM}
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index 1904416892c4..c6c88c4abde5 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1 +1,2 @@
-MD5 (hydra-2.2.tar.gz) = 05042c1add6155ea48233df05a1e37ae
+MD5 (hydra-2.6.tar.gz) = 293dbc40e9b1ae67cd74a9e5495bd389
+SIZE (hydra-2.6.tar.gz) = 48954
diff --git a/security/hydra/files/patch-hydra.c b/security/hydra/files/patch-hydra.c
deleted file mode 100644
index 9f78dad0920e..000000000000
--- a/security/hydra/files/patch-hydra.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- hydra.c.orig Fri Oct 17 16:25:46 2003
-+++ hydra.c Fri Oct 17 16:25:46 2003
-@@ -55,33 +55,30 @@
- static pid_t pids[MAXTASKS];
-
- void help() {
-- printf("%s %s (c) 2002 by %s %s
--Syntax: %s [[[-l LOGIN|-L FILE] [-p PASS|-P FILE]] | [-C FILE]] [-o FILE] [-t TASKS] [-g TASKS] [-w TIME] [-f] [-e ns] [-s PORT] [-S] server service [OPT]\n",
-+ printf("%s %s (c) 2002 by %s %s\n"\
-+"Syntax: %s [[[-l LOGIN|-L FILE] [-p PASS|-P FILE]] | [-C FILE]] [-o FILE] [-t TASKS] [-g TASKS] [-w TIME] [-f] [-e ns] [-s PORT] [-S] server service [OPT]\n",
- PROGRAM,VERSION,AUTHOR,EMAIL,prg);
- printf("\nOptions:");
- #ifdef HYDRA_SSL
--printf("
-- -S connect via SSL");
-+printf("\n -S connect via SSL");
- #endif
--printf("
-- -s PORT if the service is on a different default port, define it here
-- -l LOGIN or -L FILE login with LOGIN name, or load several logins from FILE
-- -p PASS or -P FILE try password PASS, or load several passwords from FILE
-- -e ns additional checks, \"n\" for null password, \"s\" try login as pass
-- -C FILE colon seperated \"login:pass\" format, instead of -L/-P option
-- -o FILE write found login/password pairs to FILE instead of stdout
-- -f exit after the first found login/password pair
-- -t TASKS run TASKS number of connects in parallel (default: %d)
-- -g TASKS start TASKS number per second until -t TASKS are reached
-- -w TIME in seconds, defines the max wait reply time (default: %d)
-- server the target server
-- service the service to crack. Supported protocols: [%s]
-- OPT some service modules need additional input, put it here
--
--%s is a tool to guess valid login/password pairs on a target server.
--You can always find the newest version at %s
--Use this tool only for legal purposes!
--",TASKS,WAITTIME,SERVICES,PROGRAM,RESSOURCE);
-+printf("\n"\
-+" -s PORT if the service is on a different default port, define it here\n"\
-+" -l LOGIN or -L FILE login with LOGIN name, or load several logins from FILE\n"\
-+" -p PASS or -P FILE try password PASS, or load several passwords from FILE\n"\
-+" -e ns additional checks, \"n\" for null password, \"s\" try login as pass\n"\
-+" -C FILE colon seperated \"login:pass\" format, instead of -L/-P option\n"\
-+" -o FILE write found login/password pairs to FILE instead of stdout\n"\
-+" -f exit after the first found login/password pair\n"\
-+" -t TASKS run TASKS number of connects in parallel (default: %d)\n"\
-+" -g TASKS start TASKS number per second until -t TASKS are reached\n"\
-+" -w TIME in seconds, defines the max wait reply time (default: %d)\n"\
-+" server the target server\n"\
-+" service the service to crack. Supported protocols: [%s]\n"\
-+" OPT some service modules need additional input, put it here\n\n"\
-+"%s is a tool to guess valid login/password pairs on a target server.\n"\
-+"You can always find the newest version at %s\n"\
-+"Use this tool only for legal purposes!\n",TASKS,WAITTIME,SERVICES,PROGRAM,RESSOURCE);
- exit(-1);
- }
-