aboutsummaryrefslogtreecommitdiff
path: root/security/i2p/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-01 11:34:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-01 11:34:51 +0000
commit3432e30c01de012d5580a96564d4e851e67808f4 (patch)
tree2c0400c5ff93461f890d1fb3b79c828bb1f26cea /security/i2p/Makefile
parentd11fe5b568ea79d748b103e8ae91b45da6d555b3 (diff)
downloadports-3432e30c01de012d5580a96564d4e851e67808f4.tar.gz
ports-3432e30c01de012d5580a96564d4e851e67808f4.zip
- Simplify Makefile
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=455275
Diffstat (limited to 'security/i2p/Makefile')
-rw-r--r--security/i2p/Makefile51
1 files changed, 14 insertions, 37 deletions
diff --git a/security/i2p/Makefile b/security/i2p/Makefile
index 104a0100c3e2..057a7ff951a3 100644
--- a/security/i2p/Makefile
+++ b/security/i2p/Makefile
@@ -28,8 +28,6 @@ LIB_DEPENDS= libiconv.so:converters/libiconv
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= i2p libwrapper.so library binary only available for i386 and amd64
-OPTIONS_DEFINE= DOCS
-
USES= gettext tar:bzip2
USE_RC_SUBR= i2p
@@ -39,28 +37,17 @@ JAVA_BUILD= jdk
JAVA_VERSION= 1.6+
USE_LOCALE= en_US.UTF-8
-ALL_TARGET= \
- updater \
- tarball
-
-PORTDATA= *
-
-PLIST_FILES= \
- sbin/i2prouter
+ALL_TARGET= updater tarball
SUB_FILES= wrapper.sh
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-ALL_TARGET+= javadoc
-
+PORTDATA= *
PORTDOCS= *
+PLIST_FILES= sbin/i2prouter
-JAVADOC_WRKSRC= ${WRKSRC}/build/javadoc
-.endif
+OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
+DOCS_ALL_TARGET= javadoc
post-patch:
# postinstall.sh SHOULD only do post installation house keeping
@@ -75,23 +62,13 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
-# install
- @${INSTALL_DATA} ${WRKSRC}/i2p.tar.bz2 \
- ${STAGEDIR}${DATADIR}/
-# update
- @${INSTALL_DATA} ${WRKSRC}/i2pupdate.zip \
- ${STAGEDIR}${DATADIR}/
-# wrapper
- @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh \
- ${STAGEDIR}${PREFIX}/sbin/i2prouter
-# doc
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/i2p.tar.bz2 ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/i2pupdate.zip ${STAGEDIR}${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${STAGEDIR}${PREFIX}/sbin/i2prouter
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/installer/resources/readme/readme*.html ${STAGEDIR}${DOCSDIR}
-# line taken from textproc/xerces-j maintained by hq@FreeBSD.org
- @cd ${JAVADOC_WRKSRC} && \
- ${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DOCSDIR}/{}" \; && \
- ${FIND} * -not -type d -exec ${INSTALL_DATA} {} "${STAGEDIR}${DOCSDIR}/{}" \;
-.endif
-
-.include <bsd.port.post.mk>
+ ${INSTALL_DATA} ${WRKSRC}/installer/resources/readme/readme*.html ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC}/build/javadoc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>