aboutsummaryrefslogtreecommitdiff
path: root/security/i2pd/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-28 11:27:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-28 11:27:40 +0000
commit604e84fb7441fe39187b5da02ee377fd098e4472 (patch)
tree43faa89df3996630557cdb0d4ce23e789028175e /security/i2pd/Makefile
parent2ad046d11c3bead6da39362f3c13fa17c068bed4 (diff)
downloadports-604e84fb7441fe39187b5da02ee377fd098e4472.tar.gz
ports-604e84fb7441fe39187b5da02ee377fd098e4472.zip
Notes
Diffstat (limited to 'security/i2pd/Makefile')
-rw-r--r--security/i2pd/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/i2pd/Makefile b/security/i2pd/Makefile
index d8dcb959a895..b6711f77712d 100644
--- a/security/i2pd/Makefile
+++ b/security/i2pd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= i2pd
-PORTVERSION= 2.15.0
-PORTREVISION= 3
+PORTVERSION= 2.16.0
CATEGORIES= security net-p2p
MAINTAINER= amdmi3@FreeBSD.org
@@ -20,7 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= PurpleI2P
USES= cmake compiler:c++11-lib ssl
-CMAKE_SOURCE_PATH=${WRKSRC}/build
+CMAKE_ARGS= -DWITH_GUI=OFF
+CMAKE_SOURCE_PATH= ${WRKSRC}/build
USE_RC_SUBR= ${PORTNAME}
PORTDOCS= *
@@ -32,7 +32,7 @@ PLIST_SUB= USER="${USERS}" GROUP="${GROUPS}"
SUB_LIST= USER="${USERS}" GROUP="${GROUPS}"
SUB_FILES= i2pd.newsyslog.conf
-OPTIONS_DEFINE= AESNI AVX UPNP DOCS
+OPTIONS_DEFINE= AESNI AVX UPNP DOCS HARDENING
AESNI_DESC= Use AES-NI instructions set
AESNI_CMAKE_BOOL= WITH_AESNI
@@ -41,6 +41,9 @@ AVX_CMAKE_BOOL= WITH_AVX
UPNP_DESC= Include support for UPnP client
UPNP_CMAKE_BOOL= WITH_UPNP
UPNP_LIB_DEPENDS= libminiupnpc.so:net/miniupnpc
+UPNP_DESC= Include support for UPnP client
+HARDENING_CMAKE_BOOL= WITH_HARDENING
+HARDENING_DESC= Use hardening compiler flags
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin