aboutsummaryrefslogtreecommitdiff
path: root/security/i2pd
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-28 11:27:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-28 11:27:40 +0000
commit604e84fb7441fe39187b5da02ee377fd098e4472 (patch)
tree43faa89df3996630557cdb0d4ce23e789028175e /security/i2pd
parent2ad046d11c3bead6da39362f3c13fa17c068bed4 (diff)
downloadports-604e84fb7441fe39187b5da02ee377fd098e4472.tar.gz
ports-604e84fb7441fe39187b5da02ee377fd098e4472.zip
Notes
Diffstat (limited to 'security/i2pd')
-rw-r--r--security/i2pd/Makefile11
-rw-r--r--security/i2pd/distinfo6
-rw-r--r--security/i2pd/files/patch-build_CMakeLists.txt27
3 files changed, 37 insertions, 7 deletions
diff --git a/security/i2pd/Makefile b/security/i2pd/Makefile
index d8dcb959a895..b6711f77712d 100644
--- a/security/i2pd/Makefile
+++ b/security/i2pd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= i2pd
-PORTVERSION= 2.15.0
-PORTREVISION= 3
+PORTVERSION= 2.16.0
CATEGORIES= security net-p2p
MAINTAINER= amdmi3@FreeBSD.org
@@ -20,7 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= PurpleI2P
USES= cmake compiler:c++11-lib ssl
-CMAKE_SOURCE_PATH=${WRKSRC}/build
+CMAKE_ARGS= -DWITH_GUI=OFF
+CMAKE_SOURCE_PATH= ${WRKSRC}/build
USE_RC_SUBR= ${PORTNAME}
PORTDOCS= *
@@ -32,7 +32,7 @@ PLIST_SUB= USER="${USERS}" GROUP="${GROUPS}"
SUB_LIST= USER="${USERS}" GROUP="${GROUPS}"
SUB_FILES= i2pd.newsyslog.conf
-OPTIONS_DEFINE= AESNI AVX UPNP DOCS
+OPTIONS_DEFINE= AESNI AVX UPNP DOCS HARDENING
AESNI_DESC= Use AES-NI instructions set
AESNI_CMAKE_BOOL= WITH_AESNI
@@ -41,6 +41,9 @@ AVX_CMAKE_BOOL= WITH_AVX
UPNP_DESC= Include support for UPnP client
UPNP_CMAKE_BOOL= WITH_UPNP
UPNP_LIB_DEPENDS= libminiupnpc.so:net/miniupnpc
+UPNP_DESC= Include support for UPnP client
+HARDENING_CMAKE_BOOL= WITH_HARDENING
+HARDENING_DESC= Use hardening compiler flags
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/security/i2pd/distinfo b/security/i2pd/distinfo
index 3a2e45ca6cc0..b03f6e28ba46 100644
--- a/security/i2pd/distinfo
+++ b/security/i2pd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1503228089
-SHA256 (PurpleI2P-i2pd-2.15.0_GH0.tar.gz) = 87649a1963b1d1b8f9424c0bccbdf6bbde0bb87db8dcf0b5c61f4c7f13181b86
-SIZE (PurpleI2P-i2pd-2.15.0_GH0.tar.gz) = 1834673
+TIMESTAMP = 1511264028
+SHA256 (PurpleI2P-i2pd-2.16.0_GH0.tar.gz) = 0a8fbc76422ba3452d281f31dbd55bc2e3da3b6bb2bc689b3b93c8039b6edfcd
+SIZE (PurpleI2P-i2pd-2.16.0_GH0.tar.gz) = 1872885
diff --git a/security/i2pd/files/patch-build_CMakeLists.txt b/security/i2pd/files/patch-build_CMakeLists.txt
new file mode 100644
index 000000000000..594c0d300aa3
--- /dev/null
+++ b/security/i2pd/files/patch-build_CMakeLists.txt
@@ -0,0 +1,27 @@
+--- build/CMakeLists.txt.orig 2017-11-13 19:20:41 UTC
++++ build/CMakeLists.txt
+@@ -177,11 +177,6 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wformat -Wformat-security -Werror=format-security" )
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fstack-protector --param ssp-buffer-size=4" )
+ endif ()
+-elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+- # more tweaks
+- if (NOT (MSVC OR MSYS OR APPLE))
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libstdc++" )
+- endif()
+ endif ()
+
+ if (WITH_HARDENING AND MSVC)
+@@ -461,12 +456,6 @@ if (WITH_BINARY)
+ fixup_bundle(\"${APPS}\" \"\" \"${DIRS}\")
+ " COMPONENT Runtime)
+ endif ()
+-
+- if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+- if (NOT (MSVC OR MSYS OR APPLE)) # for Clang build on Linux
+- target_link_libraries("${PROJECT_NAME}" stdc++)
+- endif()
+- endif()
+ endif ()
+
+ install(FILES ../LICENSE