aboutsummaryrefslogtreecommitdiff
path: root/security/i2pd
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-28 13:27:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-28 13:27:02 +0000
commitf4f592a8013a995fb55692f5c8e885299d822c38 (patch)
tree00b973af41e3af9a03adfce7fa017fc9c3954ca1 /security/i2pd
parent07ec6a83c61a589235dab66be0d4bf2ec9b7e6dc (diff)
downloadports-f4f592a8013a995fb55692f5c8e885299d822c38.tar.gz
ports-f4f592a8013a995fb55692f5c8e885299d822c38.zip
Notes
Diffstat (limited to 'security/i2pd')
-rw-r--r--security/i2pd/Makefile3
-rw-r--r--security/i2pd/distinfo6
-rw-r--r--security/i2pd/files/patch-build_CMakeLists.txt15
-rw-r--r--security/i2pd/files/patch-libi2pd_Crypto.h24
4 files changed, 43 insertions, 5 deletions
diff --git a/security/i2pd/Makefile b/security/i2pd/Makefile
index 84d214f2dfb3..5b6fbbe219f9 100644
--- a/security/i2pd/Makefile
+++ b/security/i2pd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= i2pd
-PORTVERSION= 2.18.0
-PORTREVISION= 2
+PORTVERSION= 2.19.0
CATEGORIES= security net-p2p
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/security/i2pd/distinfo b/security/i2pd/distinfo
index b77826d8e864..5cc2d0db3457 100644
--- a/security/i2pd/distinfo
+++ b/security/i2pd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518621300
-SHA256 (PurpleI2P-i2pd-2.18.0_GH0.tar.gz) = 8834190418de0c4e56c46eb8b9dc4422ef14f1ad7d6591e9daae99493bf7170e
-SIZE (PurpleI2P-i2pd-2.18.0_GH0.tar.gz) = 1868440
+TIMESTAMP = 1530109716
+SHA256 (PurpleI2P-i2pd-2.19.0_GH0.tar.gz) = 7202497ffc3db632d0f7fed93eafaf39aa75efea199705dae7d022249b069eb9
+SIZE (PurpleI2P-i2pd-2.19.0_GH0.tar.gz) = 1982459
diff --git a/security/i2pd/files/patch-build_CMakeLists.txt b/security/i2pd/files/patch-build_CMakeLists.txt
new file mode 100644
index 000000000000..172b41939719
--- /dev/null
+++ b/security/i2pd/files/patch-build_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- build/CMakeLists.txt.orig 2018-06-26 17:46:01 UTC
++++ build/CMakeLists.txt
+@@ -202,9 +202,11 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
+ endif ()
+ elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+ # more tweaks
+- if (NOT (MSVC OR MSYS OR APPLE))
++ if (LINUX)
+ set (CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -stdlib=libstdc++" ) # required for <atomic>
+ list(APPEND CMAKE_REQUIRED_LIBRARIES "stdc++") # required to link with -stdlib=libstdc++
++ endif()
++ if (NOT (MSVC OR MSYS OR APPLE))
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unused-const-variable -Wno-overloaded-virtual -Wno-c99-extensions" )
+ endif()
+ endif ()
diff --git a/security/i2pd/files/patch-libi2pd_Crypto.h b/security/i2pd/files/patch-libi2pd_Crypto.h
new file mode 100644
index 000000000000..a263734c74d6
--- /dev/null
+++ b/security/i2pd/files/patch-libi2pd_Crypto.h
@@ -0,0 +1,24 @@
+commit 4ffbb46cf9c63dfddc062771a9bb29a5d50524af
+Author: Dmitry Marakasov <amdmi3@amdmi3.ru>
+Date: Wed Jun 27 22:31:01 2018 +0300
+
+ Fix "macro expansion producing 'defined' has undefined behavior" clang warning
+
+diff --git libi2pd/Crypto.h libi2pd/Crypto.h
+index fe0fcddf..43f1def9 100644
+--- libi2pd/Crypto.h
++++ libi2pd/Crypto.h
+@@ -262,7 +262,12 @@ namespace crypto
+
+ // take care about openssl version
+ #include <openssl/opensslv.h>
+-#define LEGACY_OPENSSL ((OPENSSL_VERSION_NUMBER < 0x010100000) || defined(LIBRESSL_VERSION_NUMBER)) // 1.0.2 and below or LibreSSL
++#if ((OPENSSL_VERSION_NUMBER < 0x010100000) || defined(LIBRESSL_VERSION_NUMBER)) // 1.0.2 and below or LibreSSL
++# define LEGACY_OPENSSL 1
++#else
++# define LEGACY_OPENSSL 0
++#endif
++
+ #if LEGACY_OPENSSL
+ // define getters and setters introduced in 1.1.0
+ inline int DSA_set0_pqg(DSA *d, BIGNUM *p, BIGNUM *q, BIGNUM *g)