aboutsummaryrefslogtreecommitdiff
path: root/security/idea
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-06 20:47:17 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-06 20:47:17 +0000
commita7667cb24d56115a3ce19b503a1313e97698fb1b (patch)
tree68be11cf2cea086a6ea1e99c9ad33320bbf84102 /security/idea
parent375c458dbd450179b42b8a5001add5e65b9ba165 (diff)
downloadports-a7667cb24d56115a3ce19b503a1313e97698fb1b.tar.gz
ports-a7667cb24d56115a3ce19b503a1313e97698fb1b.zip
Notes
Diffstat (limited to 'security/idea')
-rw-r--r--security/idea/Makefile48
-rw-r--r--security/idea/distinfo2
-rw-r--r--security/idea/pkg-descr11
-rw-r--r--security/idea/pkg-message11
-rw-r--r--security/idea/pkg-plist6
5 files changed, 78 insertions, 0 deletions
diff --git a/security/idea/Makefile b/security/idea/Makefile
new file mode 100644
index 000000000000..9f9efb6e3aac
--- /dev/null
+++ b/security/idea/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: idea
+# Date created: 4 September 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= idea
+PORTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= http://www.funet.fi/pub/org/CERT/ftp.cert.dfn.de/pub/tools/crypt/idea/ \
+ http://www.de-moliner.ch/richard/downloads/ \
+ http://ftp.at.linuxfromscratch.org/infosys/security/dfn/tools/crypt/idea/
+DISTNAME= ${PORTNAME}.V${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line idea encryption and decryption utility
+
+RESTRICTED= "Crypto; IDEA is a patented algorithm that requires proper licensing"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MANL= idea.l
+MANCOMPRESSED= no
+
+.if !defined(MAKE_IDEA) || ${MAKE_IDEA} == "no" || ${MAKE_IDEA} == "NO"
+IGNORE= "you chose not to use idea related code"
+.endif
+
+do-build:
+ ${CC} ${WRKSRC}/idea.c ${WRKSRC}/idea_cmd.c ${CFLAGS} -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/manl/idea.l ${PREFIX}/man/manl
+ ${INSTALL_PROGRAM} -m 0555 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Examples ${EXAMPLESDIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/byte_ord.ps ${WRKSRC}/idea_cmd.txt ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/idea/distinfo b/security/idea/distinfo
new file mode 100644
index 000000000000..86249bccbb38
--- /dev/null
+++ b/security/idea/distinfo
@@ -0,0 +1,2 @@
+MD5 (idea.V1.2.tar.Z) = 2aacefa036c7df2144ae8aa5a0e413fe
+SIZE (idea.V1.2.tar.Z) = 142835
diff --git a/security/idea/pkg-descr b/security/idea/pkg-descr
new file mode 100644
index 000000000000..de3650577aed
--- /dev/null
+++ b/security/idea/pkg-descr
@@ -0,0 +1,11 @@
+A command line idea encryption and decryption utility written by
+Dr. Richard De Moliner.
+
+IDEA (International Data Encryption Algorithm) is a block cipher devel-
+oped by Dr. Xuejia Lai and Prof. Dr. J. L. Massey at the Swiss Federal
+Institute of Technology.
+
+WWW: http://www.de-moliner.ch/richard/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/security/idea/pkg-message b/security/idea/pkg-message
new file mode 100644
index 000000000000..73ef78ae5e65
--- /dev/null
+++ b/security/idea/pkg-message
@@ -0,0 +1,11 @@
+==========================================================================
+
+IDEA is registered as the international patent WO 91/18459 "Device for
+Converting a Digital Block and the Use thereof". For commercial use of
+IDEA, one should contact
+
+ASCOM TECH AG
+Freiburgstrasse 370
+CH-3018 Bern, Switzerland
+
+==========================================================================
diff --git a/security/idea/pkg-plist b/security/idea/pkg-plist
new file mode 100644
index 000000000000..caec515e858c
--- /dev/null
+++ b/security/idea/pkg-plist
@@ -0,0 +1,6 @@
+bin/idea
+%%PORTDOCS%%%%DOCSDIR%%/idea_cmd.txt
+%%PORTDOCS%%%%DOCSDIR%%/byte_ord.ps
+%%EXAMPLESDIR%%/Examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%