aboutsummaryrefslogtreecommitdiff
path: root/security/ifd-gpr400
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
commit384c2bae3b94d68ec15491eba4dc6c00acfb93ea (patch)
treefa1875a4f3aa5c20bbc367e43e857f6c786b914f /security/ifd-gpr400
parent2a7193c97879226f0631d791aecbcac01770058f (diff)
downloadports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.tar.gz
ports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.zip
Notes
Diffstat (limited to 'security/ifd-gpr400')
-rw-r--r--security/ifd-gpr400/Makefile2
-rw-r--r--security/ifd-gpr400/files/patch-Makefile60
-rw-r--r--security/ifd-gpr400/files/patch-gpr400_ifd.c21
3 files changed, 46 insertions, 37 deletions
diff --git a/security/ifd-gpr400/Makefile b/security/ifd-gpr400/Makefile
index c130e86d696f..a3268b384adc 100644
--- a/security/ifd-gpr400/Makefile
+++ b/security/ifd-gpr400/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= bms@FreeBSD.org
COMMENT= PC/SC Lite driver for Gemplus GPR400 PCMCIA Smart Card Readers
BUILD_DEPENDS= ${LOCALBASE}/include/ifdhandler.h:${PORTSDIR}/security/ifd-devkit
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
MAKE_ENV+= DESTDIR="${PREFIX}"
diff --git a/security/ifd-gpr400/files/patch-Makefile b/security/ifd-gpr400/files/patch-Makefile
index 08bead01bc8f..2fe1fd689fe1 100644
--- a/security/ifd-gpr400/files/patch-Makefile
+++ b/security/ifd-gpr400/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Aug 9 06:14:42 2001
-+++ Makefile Sun Sep 8 18:11:11 2002
-@@ -1,36 +1,41 @@
+--- Makefile.orig Thu Aug 9 07:14:42 2001
++++ Makefile Mon Apr 11 21:07:03 2005
+@@ -1,36 +1,39 @@
-# GPR400 IFD Handler Makefile
-#
-# Author: Joe Phillips <joe.phillips@innovationsw.com>
@@ -16,32 +16,43 @@
-LEX = flex
-OBJ := $(filter-out test.o, $(patsubst %.c,%.o,$(wildcard *.c)))
-INCLUDE = -I.
-+#XXX
-+PREFIX?= /usr/local
+DESTDIR?= ${PREFIX}
-+
+
+-MAKEXE = make
+-LIBNAME = libgpr400_ifd.so
+-PREFIX = /usr/local/pcsc
+# XXX
+LIBDIR= /lib
+#LIBDIR= /pcsc
+INCSDIR= /include
-+
+
+-DEFS = -DPCSC_DEBUG=1 #-DATR_DEBUG=1
+SHLIB_NAME= libgpr400_ifd.so
+SHLIB_MAJOR= 0
+SHLIB_MINOR= 3
-+
+
+-all: unix
+NOMAN= 1
+NOPROFILE= 1
-+
+
+-clean:
+- rm -f *.o $(LIBNAME) core
+.if !defined(NO_DEBUG)
+CFLAGS+= -g -Wall
+.endif
-+
+
+-osx: $(OBJ)
+- $(CC) -dynamiclib $(OBJ) -o $(LIBNAME)
+GPRDEVNAME?= /dev/gprsc0
-+
-+CFLAGS+= -I. -I${DESTDIR}${INCSDIR} -DGPRDEVNAME=\"${GPRDEVNAME}\"
+
+-unix: $(OBJ)
+- $(LD) -shared $(OBJ) -o $(LIBNAME)
++CFLAGS+= -I. -I${DESTDIR}${INCSDIR}/PCSC -I${DESTDIR}${INCSDIR} -DGPRDEVNAME=\"${GPRDEVNAME}\"
+LDFLAGS+= -L${DESTDIR}/lib
+LDADD+= -lpcsclite
-+
+
+-$(patsubst %.c,%.o,$(wildcard *.c)) : %.o : %.c
+- $(CC) $(CFLAGS) -c $< $(INCLUDE) $(DEFS)
+.if !defined(NO_PCSC_DEBUG)
+CFLAGS+= -DPCSC_DEBUG=1
+.if defined(PCSC_ATR_DEBUG)
@@ -49,27 +60,8 @@
+.endif
+.endif
--MAKEXE = make
--LIBNAME = libgpr400_ifd.so
--PREFIX = /usr/local/pcsc
+-##
+SRCS= gpr400_ifd.c
+INCS= gpr400.h
-
--DEFS = -DPCSC_DEBUG=1 #-DATR_DEBUG=1
--
--all: unix
--
--clean:
-- rm -f *.o $(LIBNAME) core
--
--osx: $(OBJ)
-- $(CC) -dynamiclib $(OBJ) -o $(LIBNAME)
--
--unix: $(OBJ)
-- $(LD) -shared $(OBJ) -o $(LIBNAME)
--
--$(patsubst %.c,%.o,$(wildcard *.c)) : %.o : %.c
-- $(CC) $(CFLAGS) -c $< $(INCLUDE) $(DEFS)
--
--##
++
+.include <bsd.lib.mk>
diff --git a/security/ifd-gpr400/files/patch-gpr400_ifd.c b/security/ifd-gpr400/files/patch-gpr400_ifd.c
index ff08a8b8f152..eab88a809cfc 100644
--- a/security/ifd-gpr400/files/patch-gpr400_ifd.c
+++ b/security/ifd-gpr400/files/patch-gpr400_ifd.c
@@ -1,5 +1,5 @@
---- gpr400_ifd.c.orig Wed Aug 22 03:21:43 2001
-+++ gpr400_ifd.c Sun Sep 8 18:10:47 2002
+--- gpr400_ifd.c.orig Wed Aug 22 04:21:43 2001
++++ gpr400_ifd.c Mon Apr 11 21:09:23 2005
@@ -77,7 +77,7 @@
printf("IFDHCreateChannel:\n");
#endif
@@ -9,3 +9,20 @@
if(gpr_fd < 0){
return IFD_COMMUNICATION_ERROR;
}
+@@ -597,16 +597,6 @@
+ RxLength should be zero on error.
+ *
+ **/
+-RESPONSECODE IFDHControl ( DWORD Lun, PUCHAR TxBuffer,
+- DWORD TxLength, PUCHAR RxBuffer,
+- PDWORD RxLength )
+-{
+-#ifdef PCSC_DEBUG
+- printf("IFDHControl:\n");
+-#endif
+- return IFD_NOT_SUPPORTED;
+-
+-}/* IFDHControl */
+
+ /**
+ * check if there is a smartcard in the reader