aboutsummaryrefslogtreecommitdiff
path: root/security/ike/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-16 11:07:29 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-16 11:07:29 +0000
commit7117ed4a934f46969a230b2ef52104a61172429d (patch)
tree9fc3b997df2acb60f556332ee504bad77ff6c370 /security/ike/Makefile
parent6c4931fe4d140b32da1683798b47a253c8818ec8 (diff)
downloadports-7117ed4a934f46969a230b2ef52104a61172429d.tar.gz
ports-7117ed4a934f46969a230b2ef52104a61172429d.zip
Notes
Diffstat (limited to 'security/ike/Makefile')
-rw-r--r--security/ike/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
index cdfa2523ba79..9b2b5631ab28 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -17,7 +17,7 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
-USE_RC_SUBR= iked
+USE_RC_SUBR= iked
USE_BISON= build
USE_OPENSSL= yes
USE_CMAKE= yes
@@ -25,17 +25,20 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+CMAKE_ARGS+= -DETCDIR:PATH="${PREFIX}/etc" \
+ -DLIBDIR:PATH="${PREFIX}/lib" \
+ -DMANDIR:PATH="${PREFIX}/man"
+
OPTIONS= QTGUI "Enable QT client front end applications" on \
NATT "Enable NAT-Traversal (kernel-patch required)" off \
LDAP "Enable LDAP XAuth daemon support" off \
DEBUG "Enable Debug support" off
-MAN1= ikea.1 ikec.1
+.include <bsd.port.options.mk>
+
MAN5= iked.conf.5
MAN8= iked.8
-.include <bsd.port.pre.mk>
-
.ifdef(WITH_DEBUG)
CMAKE_ARGS+= -DDEBUG=YES
.endif
@@ -51,9 +54,15 @@ CMAKE_ARGS+= -DNATT=YES
.ifdef(WITH_QTGUI)
CMAKE_ARGS+= -DQTGUI=YES
-LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
+USE_QT_VER= 3
+MAN1= ikea.1 ikec.1
+PLIST_SUB+= QTGUI=""
+.else
+PLIST_SUB+= QTGUI="@comment "
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
.if defined(WITH_NATT)
. if ${OSVERSION} < 800000
@@ -73,6 +82,8 @@ post-patch:
@sleep 3
. endif
.endif
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
+ ${WRKSRC}/CMakeLists.txt
post-build:
# QT 3.3 UIC (User Interface Compiler) creates these, so remove them.