aboutsummaryrefslogtreecommitdiff
path: root/security/ike
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-10-31 00:17:43 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-10-31 00:17:43 +0000
commitb56a5d392ae267283afe9d66124eaa52e3087f86 (patch)
treea8485661b6be0235b6ef5289773135c1d763bb6b /security/ike
parent3ff0acd28e99687cb71a6b12ad250ae86c801caa (diff)
downloadports-b56a5d392ae267283afe9d66124eaa52e3087f86.tar.gz
ports-b56a5d392ae267283afe9d66124eaa52e3087f86.zip
Notes
Diffstat (limited to 'security/ike')
-rw-r--r--security/ike/Makefile47
-rw-r--r--security/ike/distinfo6
-rw-r--r--security/ike/files/patch-source_iked_conf.parse.yy20
-rw-r--r--security/ike/pkg-plist4
4 files changed, 32 insertions, 45 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
index 0001ba47ed46..cdfa2523ba79 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ike
-PORTVERSION= 2.1.4
-PORTREVISION= 2
+PORTVERSION= 2.1.7
CATEGORIES= security net
MASTER_SITES= http://www.shrew.net/download/ike/
DISTNAME= ${PORTNAME}-${PORTVERSION}-release
@@ -18,6 +17,7 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
+USE_RC_SUBR= iked
USE_BISON= build
USE_OPENSSL= yes
USE_CMAKE= yes
@@ -55,25 +55,23 @@ LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
.endif
post-patch:
-.ifdef(WITH_NATT)
+.if defined(WITH_NATT)
+. if ${OSVERSION} < 800000
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
- @${ECHO_MSG} "===> ATTENTION: You need a kernel patch to enable NAT-Traversal functionality!"
-. if ${OSVERSION} < 600000
- @${ECHO_MSG} "===> There is no known NAT-T patch for FreeBSD 1 - 5!!!"
-. endif
-. if ${OSVERSION} > 600000 && ${OSVERSION} < 699999
- @${ECHO_MSG} "===> http://ipsec-tools.sf.net/freebsd6-natt.diff"
-. endif
-. if ${OSVERSION} > 700000 && ${OSVERSION} < 799999
- @${ECHO_MSG} "===> http://vanhu.free.fr/FreeBSD/patch-natt-freebsd7-2007-10-22.diff"
-. endif
-. if ${OSVERSION} > 800000
- @${ECHO_MSG} "===> http://vanhu.free.fr/FreeBSD/patch-natt-freebsd-HEAD-2007-10-22.diff"
-. endif
- @${ECHO_MSG} "===> You might possibly have to do some steps manually if it fails to apply."
+ @${ECHO_MSG} "===> WARNING: You will need to patch your kernel for NAT-T functionality!"
+. if ${OSVERSION} < 600000
+ @${ECHO_MSG} "===> There is no known NAT-T patch for FreeBSD 1 - 5!!!"
+. endif
+. if ${OSVERSION} > 600000 && ${OSVERSION} < 699999
+ @${ECHO_MSG} "===> http://ipsec-tools.sf.net/freebsd6-natt.diff"
+. endif
+. if ${OSVERSION} > 700000 && ${OSVERSION} < 799999
+ @${ECHO_MSG} "===> http://people.freebsd.org/~vanhu/NAT-T/patch-natt-7.2-2009-05-12.diff"
+. endif
+ @${ECHO_MSG} "===> You may need to edit the patch if it fails to apply cleanly."
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
-
@sleep 3
+. endif
.endif
post-build:
@@ -86,8 +84,17 @@ post-build:
post-install:
@if ! ${SYSCTL} -a | ${GREP} -q ipsec; then \
- ${ECHO_MSG} "WARNING: IPsec feature is disabled on this host"; \
- ${ECHO_MSG} " You must configure a kernel with this option to use this software"; \
+ ${ECHO_MSG} "===> -------------------------------------------------------------------------"; \
+ ${ECHO_MSG} "===> WARNNG: You need IPsec support in your kernel, please see:"; \
+ ${ECHO_MSG} "===> http://www.freebsd.org/doc/en/books/handbook/ipsec.html"; \
+ ${ECHO_MSG} "===> -------------------------------------------------------------------------"; \
fi ;
+.if defined(WITH_NATT)
+ @${ECHO_MSG} "===> -------------------------------------------------------------------------"
+ @${ECHO_MSG} "===> WARNING: To use NAT Traversal ( NAT-T ) support, please be sure to"
+ @${ECHO_MSG} "===> include the following line in your kernel config file."
+ @${ECHO_MSG} "===> options IPSEC_NAT_T"
+ @${ECHO_MSG} "===> -------------------------------------------------------------------------"
+.endif
.include <bsd.port.post.mk>
diff --git a/security/ike/distinfo b/security/ike/distinfo
index 36a7b4291e29..3cf0bb6bacdc 100644
--- a/security/ike/distinfo
+++ b/security/ike/distinfo
@@ -1,3 +1,3 @@
-MD5 (ike-2.1.4-release.tbz2) = 1b855717698ba62781284b202aa72a98
-SHA256 (ike-2.1.4-release.tbz2) = 8c587e71af361ecb383c99dea0ae01b45f6206a23de8d113c75e996729dc5677
-SIZE (ike-2.1.4-release.tbz2) = 575785
+MD5 (ike-2.1.7-release.tbz2) = bc86e101809fc750013e18480c8c1040
+SHA256 (ike-2.1.7-release.tbz2) = 28e64efcec165522a775657a6c2c2263a3d03a78b114f62f5e30f4d38602edba
+SIZE (ike-2.1.7-release.tbz2) = 581284
diff --git a/security/ike/files/patch-source_iked_conf.parse.yy b/security/ike/files/patch-source_iked_conf.parse.yy
deleted file mode 100644
index 437ff8aaf213..000000000000
--- a/security/ike/files/patch-source_iked_conf.parse.yy
+++ /dev/null
@@ -1,20 +0,0 @@
---- source/iked/conf.parse.yy.orig 2008-06-10 04:24:20.000000000 +0200
-+++ source/iked/conf.parse.yy 2009-03-06 11:40:56.000000000 +0100
-@@ -43,7 +43,7 @@
- %defines
- %define "parser_class_name" "conf_parser"
-
--%{
-+%code requires {
-
- #include <string>
-
-@@ -51,7 +51,7 @@
-
- typedef class _IKED IKED;
-
--%}
-+}
-
- // The parsing context.
- %parse-param { IKED & iked }
diff --git a/security/ike/pkg-plist b/security/ike/pkg-plist
index 2ed2e5230ff4..85253e162cf8 100644
--- a/security/ike/pkg-plist
+++ b/security/ike/pkg-plist
@@ -5,6 +5,6 @@ sbin/iked
bin/ikea
bin/ikec
lib/libike.so
-lib/libike.so.2.1.4
+lib/libike.so.2.1.7
lib/libpfk.so
-lib/libpfk.so.2.1.4
+lib/libpfk.so.2.1.7