aboutsummaryrefslogtreecommitdiff
path: root/security/ike
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-16 11:07:29 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-16 11:07:29 +0000
commit7117ed4a934f46969a230b2ef52104a61172429d (patch)
tree9fc3b997df2acb60f556332ee504bad77ff6c370 /security/ike
parent6c4931fe4d140b32da1683798b47a253c8818ec8 (diff)
- Fix plist when WITHOUT_QTGUI=yes
- Make install PREFIX safe PR: ports/154973 Submitted by: Yuri Pankov <yuri.pankov@gmail.com> Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=283599
Diffstat (limited to 'security/ike')
-rw-r--r--security/ike/Makefile21
-rw-r--r--security/ike/files/patch-CMakeLists.txt23
-rw-r--r--security/ike/pkg-plist4
3 files changed, 41 insertions, 7 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
index cdfa2523ba79..9b2b5631ab28 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -17,7 +17,7 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
-USE_RC_SUBR= iked
+USE_RC_SUBR= iked
USE_BISON= build
USE_OPENSSL= yes
USE_CMAKE= yes
@@ -25,17 +25,20 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+CMAKE_ARGS+= -DETCDIR:PATH="${PREFIX}/etc" \
+ -DLIBDIR:PATH="${PREFIX}/lib" \
+ -DMANDIR:PATH="${PREFIX}/man"
+
OPTIONS= QTGUI "Enable QT client front end applications" on \
NATT "Enable NAT-Traversal (kernel-patch required)" off \
LDAP "Enable LDAP XAuth daemon support" off \
DEBUG "Enable Debug support" off
-MAN1= ikea.1 ikec.1
+.include <bsd.port.options.mk>
+
MAN5= iked.conf.5
MAN8= iked.8
-.include <bsd.port.pre.mk>
-
.ifdef(WITH_DEBUG)
CMAKE_ARGS+= -DDEBUG=YES
.endif
@@ -51,9 +54,15 @@ CMAKE_ARGS+= -DNATT=YES
.ifdef(WITH_QTGUI)
CMAKE_ARGS+= -DQTGUI=YES
-LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
+USE_QT_VER= 3
+MAN1= ikea.1 ikec.1
+PLIST_SUB+= QTGUI=""
+.else
+PLIST_SUB+= QTGUI="@comment "
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
.if defined(WITH_NATT)
. if ${OSVERSION} < 800000
@@ -73,6 +82,8 @@ post-patch:
@sleep 3
. endif
.endif
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
+ ${WRKSRC}/CMakeLists.txt
post-build:
# QT 3.3 UIC (User Interface Compiler) creates these, so remove them.
diff --git a/security/ike/files/patch-CMakeLists.txt b/security/ike/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..fef73481d61f
--- /dev/null
+++ b/security/ike/files/patch-CMakeLists.txt
@@ -0,0 +1,23 @@
+--- ./CMakeLists.txt.orig 2011-02-23 17:46:26.964357643 +0300
++++ ./CMakeLists.txt 2011-02-23 17:56:25.405358356 +0300
+@@ -62,13 +62,13 @@
+ # Path Option Checks
+ #
+
+-if( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
+-
+- set(
+- CMAKE_INSTALL_PREFIX
+- "/usr" )
+-
+-endif( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
++#if( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
++#
++# set(
++# CMAKE_INSTALL_PREFIX
++# "/usr" )
++#
++#endif( NOT EXISTS ${CMAKE_INSTALL_PREFIX} )
+
+ message(
+ STATUS \ No newline at end of file
diff --git a/security/ike/pkg-plist b/security/ike/pkg-plist
index 85253e162cf8..9ae22fbd5f7f 100644
--- a/security/ike/pkg-plist
+++ b/security/ike/pkg-plist
@@ -2,8 +2,8 @@
etc/iked.conf.sample
@exec [ -f %D/etc/iked.conf ] || cp %D/etc/iked.conf.sample %D/etc/iked.conf
sbin/iked
-bin/ikea
-bin/ikec
+%%QTGUI%%bin/ikea
+%%QTGUI%%bin/ikec
lib/libike.so
lib/libike.so.2.1.7
lib/libpfk.so