aboutsummaryrefslogtreecommitdiff
path: root/security/ipfcount/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2005-12-22 15:52:43 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2005-12-22 15:52:43 +0000
commitdbf9464889dd9ab42c7d66f67cd3945db652132e (patch)
treedebcbfcea68f3a6595aeebf85148415e04efc4ef /security/ipfcount/Makefile
parent8880c44cdc0f0842f6c6913b41dd345b0dce0c11 (diff)
downloadports-dbf9464889dd9ab42c7d66f67cd3945db652132e.tar.gz
ports-dbf9464889dd9ab42c7d66f67cd3945db652132e.zip
Notes
Diffstat (limited to 'security/ipfcount/Makefile')
-rw-r--r--security/ipfcount/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/security/ipfcount/Makefile b/security/ipfcount/Makefile
new file mode 100644
index 000000000000..b4a1e44c0777
--- /dev/null
+++ b/security/ipfcount/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ipfcount
+# Date created: 22 December 2005
+# Whom: Robert Archer <freebsd@deathbeforedecaf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipfcount
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= http://deathbeforedecaf.net/misc/ports/ \
+ http://users.netleader.com.au/~rob/
+
+MAINTAINER= freebsd@deathbeforedecaf.net
+COMMENT= Summarise ipf logs by counting and sorting the fields
+
+PLIST_FILES= bin/ipfcount \
+ %%EXAMPLESDIR%%/100.ipfcount
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+MAN1= ipfcount.1
+
+SUB_FILES= pkg-message
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 5006
+IGNORE= requires perl 5.6 or higher - see the lang/perl5.8 port
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '1s,^#![^ ]*,#!${PERL},' ${WRKSRC}/ipfcount
+
+do-build:
+ cd ${WRKSRC} && pod2man ipfcount > ipfcount.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ipfcount ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ipfcount.1 ${PREFIX}/man/man1/ipfcount.1
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/100.ipfcount ${EXAMPLESDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>