aboutsummaryrefslogtreecommitdiff
path: root/security/ipfw2dshield
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-10 22:14:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-10 22:14:30 +0000
commita941169f87749d511c7c7e83e037039f561e2c84 (patch)
tree820caa6823960d184e0af0c590b76feb5097f21f /security/ipfw2dshield
parentcb829aa67b67486cc32d2e628e4264fca2b7f94a (diff)
downloadports-a941169f87749d511c7c7e83e037039f561e2c84.tar.gz
ports-a941169f87749d511c7c7e83e037039f561e2c84.zip
Notes
Diffstat (limited to 'security/ipfw2dshield')
-rw-r--r--security/ipfw2dshield/Makefile17
-rw-r--r--security/ipfw2dshield/files/patch-Makefile12
-rw-r--r--security/ipfw2dshield/files/patch-ipaddr_Makefile11
-rw-r--r--security/ipfw2dshield/files/patch-strpdate_Makefile11
4 files changed, 16 insertions, 35 deletions
diff --git a/security/ipfw2dshield/Makefile b/security/ipfw2dshield/Makefile
index 77fea8579c76..3a26597b33cc 100644
--- a/security/ipfw2dshield/Makefile
+++ b/security/ipfw2dshield/Makefile
@@ -6,21 +6,22 @@ PORTVERSION= 0.5
CATEGORIES= security
MASTER_SITES= http://www.dynamical-systems.org/ipfw/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= DShield client for ipfw logs
PORTDOCS= CHANGES README.html README.txt
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/ipfw2dshield
+ @${REINPLACE_CMD} -E -e '/^(CC|CFLAGS|prefix)/ s|=|?=|' \
+ -e 's|bindir)|DESTDIR)$$(&|' \
+ ${WRKSRC}/ipaddr/Makefile \
+ ${WRKSRC}/strpdate/Makefile
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/ipfw2dshield/files/patch-Makefile b/security/ipfw2dshield/files/patch-Makefile
index 0cfcba8f9a38..97070322aefe 100644
--- a/security/ipfw2dshield/files/patch-Makefile
+++ b/security/ipfw2dshield/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat May 29 16:27:21 2004
-+++ Makefile Fri Jun 11 15:41:20 2004
+--- Makefile.orig 2004-05-29 16:27:21.000000000 +0200
++++ Makefile 2014-07-11 00:00:21.463847887 +0200
@@ -4,7 +4,8 @@
RMCMD = rm -f
INSTALL = install
@@ -10,12 +10,14 @@
sbindir = $(prefix)/sbin
SUBDIRS = ipaddr strpdate
-@@ -29,12 +30,12 @@
+@@ -28,13 +29,13 @@
+ install: $(RC)
@for subdir in $(SUBDIRS); do (cd $$subdir && make install) ; done
@[ -d $(sbindir) ] || mkdir -vp $(sbindir)
- $(INSTALL) -c -m 700 -o root $(PROGRAM) $(sbindir)
+- $(INSTALL) -c -m 700 -o root $(PROGRAM) $(sbindir)
- $(INSTALL) -c -m 600 -o root $(RC) $(HOME)/.$(RC).sample
-+ $(INSTALL) -c -m 600 -o root $(RC) $(etcdir)/$(RC).sample
++ $(INSTALL) -c -m 700 $(PROGRAM) $(DESTDIR)$(sbindir)
++ $(INSTALL) -c -m 600 $(RC) $(DESTDIR)$(etcdir)/$(RC).sample
uninstall:
@for subdir in $(SUBDIRS); do (cd $$subdir && make uninstall) ; done
diff --git a/security/ipfw2dshield/files/patch-ipaddr_Makefile b/security/ipfw2dshield/files/patch-ipaddr_Makefile
deleted file mode 100644
index 692462426805..000000000000
--- a/security/ipfw2dshield/files/patch-ipaddr_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ipaddr/Makefile.orig Fri Feb 15 12:39:34 2002
-+++ ipaddr/Makefile Sat Nov 27 03:40:11 2004
-@@ -27,7 +27,7 @@
- CC = cc
- CFLAGS = -O2 -Wall
-
--prefix = /usr/local
-+prefix = ${PREFIX}
- bindir = $(prefix)/bin
-
- SRCS = ipaddr.c
diff --git a/security/ipfw2dshield/files/patch-strpdate_Makefile b/security/ipfw2dshield/files/patch-strpdate_Makefile
deleted file mode 100644
index f64dfdcbe6e5..000000000000
--- a/security/ipfw2dshield/files/patch-strpdate_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- strpdate/Makefile.orig Wed May 12 09:14:36 2004
-+++ strpdate/Makefile Sat Nov 27 03:40:53 2004
-@@ -27,7 +27,7 @@
- CC = cc
- CFLAGS = -O2 -Wall
-
--prefix = /usr/local
-+prefix = ${PREFIX}
- bindir = $(prefix)/bin
-
- SRCS = strpdate.c