aboutsummaryrefslogtreecommitdiff
path: root/security/ipguard/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-03 18:51:19 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-03 18:51:19 +0000
commit7de2a188119a2f068029e15d033e9f04d1a6adc9 (patch)
tree7032af6dcffc2a756eb773a7885e5d83b419e9f9 /security/ipguard/Makefile
parent5d3e7f35e7b6146f5a3facb39769905325351226 (diff)
Notes
Diffstat (limited to 'security/ipguard/Makefile')
-rw-r--r--security/ipguard/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/ipguard/Makefile b/security/ipguard/Makefile
new file mode 100644
index 000000000000..82057ab281ba
--- /dev/null
+++ b/security/ipguard/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ipguard
+# Date created: 2 Sep 2005
+# Whom: SeaD
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipguard
+PORTVERSION= 0.04
+CATEGORIES= security net
+MASTER_SITES= http://ipguard.deep.perm.ru/files/
+
+MAINTAINER= sead@mail.ru
+COMMENT= Tool designed to protect LAN IP adress space by ARP spoofing
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+MAN8= ipguard.8
+
+ETHERS?= /etc/ethers
+
+MAKE_ARGS+= ETHERS=${ETHERS}
+
+SUB_FILES= pkg-message
+SUB_LIST= ETHERS=${ETHERS}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ipguard ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/doc/ipguard.8 ${MANPREFIX}/man/man8
+ ${INSTALL_SCRIPT} ${WRKSRC}/doc/ipguard.sh.sample ${PREFIX}/etc/rc.d
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>