aboutsummaryrefslogtreecommitdiff
path: root/security/ipsec-tools
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-25 21:39:29 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-25 21:39:29 +0000
commitb190a8cde5c5cf6c5b7f0f293bc7c1b8603bfabd (patch)
tree2141da61aa0f2a448e4bd148cbc27cc7e555ac50 /security/ipsec-tools
parent64b4e6da777931dd0998a0ee2e1ab6ab98290fd5 (diff)
downloadports-b190a8cde5c5cf6c5b7f0f293bc7c1b8603bfabd.tar.gz
ports-b190a8cde5c5cf6c5b7f0f293bc7c1b8603bfabd.zip
Notes
Diffstat (limited to 'security/ipsec-tools')
-rw-r--r--security/ipsec-tools/Makefile2
-rw-r--r--security/ipsec-tools/distinfo6
-rw-r--r--security/ipsec-tools/files/patch-crypto_openssl.c40
3 files changed, 4 insertions, 44 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 35e223c01808..0bfb7de2e639 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -10,7 +10,7 @@
# - $LOCALBASE/sbin/setkey Vs /usr/sbin/setkey
PORTNAME= ipsec-tools
-PORTVERSION= 0.7
+PORTVERSION= 0.7.1
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/ipsec-tools/distinfo b/security/ipsec-tools/distinfo
index 58eac3740d00..831b66f0c68d 100644
--- a/security/ipsec-tools/distinfo
+++ b/security/ipsec-tools/distinfo
@@ -1,3 +1,3 @@
-MD5 (ipsec-tools-0.7.tar.bz2) = c0a586924edde35264ecfe94ad1c261f
-SHA256 (ipsec-tools-0.7.tar.bz2) = e99919b0ffcd86e10775ef039c340b50e45d6a4169a8465263c86b62addf0ff4
-SIZE (ipsec-tools-0.7.tar.bz2) = 645146
+MD5 (ipsec-tools-0.7.1.tar.bz2) = 30b196a2829556182c39aed9f83c0bbf
+SHA256 (ipsec-tools-0.7.1.tar.bz2) = ca9895808d354cc3e1c114687bb66a5f8efac2c6c42fce39687b369624c62fc0
+SIZE (ipsec-tools-0.7.1.tar.bz2) = 784046
diff --git a/security/ipsec-tools/files/patch-crypto_openssl.c b/security/ipsec-tools/files/patch-crypto_openssl.c
deleted file mode 100644
index 13eb30e3f13e..000000000000
--- a/security/ipsec-tools/files/patch-crypto_openssl.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/racoon/crypto_openssl.c.orig 2006-12-18 16:18:10.000000000 +0600
-+++ src/racoon/crypto_openssl.c 2008-03-28 16:36:05.000000000 +0600
-@@ -1391,15 +1391,15 @@
- RC5_32_KEY ks;
-
- /* in RFC 2451, there is information about the number of round. */
-- RC5_32_set_key(&ks, key->l, key->v, 16);
-+ RC5_32_set_key(&ks, key->l, (unsigned char*)key->v, 16);
-
- /* allocate buffer for result */
- if ((res = vmalloc(data->l)) == NULL)
- return NULL;
-
- /* decryption data */
-- RC5_32_cbc_encrypt(data->v, res->v, data->l,
-- &ks, iv->v, RC5_ENCRYPT);
-+ RC5_32_cbc_encrypt( (unsigned char*)data->v, (unsigned char*)res->v, data->l,
-+ &ks, (unsigned char*)iv->v, RC5_ENCRYPT);
-
- return res;
- }
-@@ -1412,15 +1412,15 @@
- RC5_32_KEY ks;
-
- /* in RFC 2451, there is information about the number of round. */
-- RC5_32_set_key(&ks, key->l, key->v, 16);
-+ RC5_32_set_key(&ks, key->l, (unsigned char*)key->v, 16);
-
- /* allocate buffer for result */
- if ((res = vmalloc(data->l)) == NULL)
- return NULL;
-
- /* decryption data */
-- RC5_32_cbc_encrypt(data->v, res->v, data->l,
-- &ks, iv->v, RC5_DECRYPT);
-+ RC5_32_cbc_encrypt( (unsigned char*)data->v, (unsigned char*)res->v, data->l,
-+ &ks, (unsigned char*)iv->v, RC5_DECRYPT);
-
- return res;
- }