aboutsummaryrefslogtreecommitdiff
path: root/security/isakmpd/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-05-20 02:31:11 +0000
committerWill Andrews <will@FreeBSD.org>2001-05-20 02:31:11 +0000
commitf3285252626b49cb88a8b6ead83989b08ffe9105 (patch)
tree32261d988708908eed5f9bfa1b2e390ccc7738c3 /security/isakmpd/Makefile
parentb5ac33e35883052df908732714a82c053eed6e4f (diff)
downloadports-f3285252626b49cb88a8b6ead83989b08ffe9105.tar.gz
ports-f3285252626b49cb88a8b6ead83989b08ffe9105.zip
Notes
Diffstat (limited to 'security/isakmpd/Makefile')
-rw-r--r--security/isakmpd/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
new file mode 100644
index 000000000000..63ad10b413ee
--- /dev/null
+++ b/security/isakmpd/Makefile
@@ -0,0 +1,32 @@
+# New ports collection Makefile for: ISAKMP daemon
+# Date created: Fri May 11 18:20:02 EEST 2001
+# Whom: Martti Kuparinen <martti.kuparinen@iki.fi>
+#
+# $FreeBSD$
+#
+# NOTE: See NetBSD's /usr/pkgsrc/security/isakmpd if this package
+# should be updated!
+#
+
+PORTNAME= isakmpd
+PORTVERSION= 20010403
+CATEGORIES= security net
+MASTER_SITES= ${MASTER_SITE_NETBSD}
+MASTER_SITE_SUBDIR= LOCAL_PORTS
+
+MAINTAINER= ports@FreeBSD.org
+
+# this is not compatible with cross build - there's no other way
+.if !exists(/usr/include/netinet6/ipsec.h)
+BROKEN= "requires IPsec support"
+.endif
+
+USE_SSL= yes
+WRKSRC= ${WRKDIR}/isakmpd
+MAKE_ENV+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
+
+MAN5= isakmpd.conf.5 isakmpd.policy.5
+MAN8= isakmpd.8
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>