aboutsummaryrefslogtreecommitdiff
path: root/security/ismtp
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-05-26 21:59:58 +0000
committerSteve Wills <swills@FreeBSD.org>2019-05-26 21:59:58 +0000
commit4a0f3bd93ca1c488f14d1be4243c95541a7818c9 (patch)
treeb7ca5d0cb41eed051e9af599de6d15e0459965d1 /security/ismtp
parent1bd025321dbec0867b22430588f7575f413eff45 (diff)
downloadports-4a0f3bd93ca1c488f14d1be4243c95541a7818c9.tar.gz
ports-4a0f3bd93ca1c488f14d1be4243c95541a7818c9.zip
security/ismtp: create port
SMTP user enumeration (RCPT TO and VRFY), internal spoofing, and open relay. A tool that tested for all three and with great flexibility. iSMTP does just that, making it much easier to knock that process out of the way. WWW: https://github.com/altjx/ipwn/tree/master/iSMTP PR: 231920 Submitted by: Rihaz Jerrin <rihaz.jerrin@gmail.com>
Notes
Notes: svn path=/head/; revision=502752
Diffstat (limited to 'security/ismtp')
-rw-r--r--security/ismtp/Makefile30
-rw-r--r--security/ismtp/distinfo3
-rw-r--r--security/ismtp/files/patch-iSMTP.py11
-rw-r--r--security/ismtp/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/security/ismtp/Makefile b/security/ismtp/Makefile
new file mode 100644
index 000000000000..8050ce12800c
--- /dev/null
+++ b/security/ismtp/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= ismtp
+DISTVERSION= g20180824
+CATEGORIES= security
+MASTER_SITES= GH
+
+MAINTAINER= rihaz.jerrin@gmail.com
+COMMENT= Test for SMTP user enumeration,internal spoofing, and relay
+
+LICENSE= MIT
+
+USES= python:2.7 shebangfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= altjx
+GH_PROJECT= ipwn
+GH_TAGNAME= 32bbc05
+GH_SUBDIR= iSMTP
+
+NO_BUILD= yes
+
+SHEBANG_FILES= ${WRKSRC}/${GH_SUBDIR}/iSMTP.py
+
+PLIST_FILES= bin/ismtp
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/iSMTP.py ${STAGEDIR}${PREFIX}/bin/ismtp
+
+.include <bsd.port.mk>
diff --git a/security/ismtp/distinfo b/security/ismtp/distinfo
new file mode 100644
index 000000000000..a78281a03ca1
--- /dev/null
+++ b/security/ismtp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540519577
+SHA256 (altjx-ipwn-g20180824-32bbc05_GH0.tar.gz) = e45307700c9061222c83200f87757eb0977a2f4d28473b35cbbc432a0d7f4092
+SIZE (altjx-ipwn-g20180824-32bbc05_GH0.tar.gz) = 38221
diff --git a/security/ismtp/files/patch-iSMTP.py b/security/ismtp/files/patch-iSMTP.py
new file mode 100644
index 000000000000..e692d18e6ccf
--- /dev/null
+++ b/security/ismtp/files/patch-iSMTP.py
@@ -0,0 +1,11 @@
+--- iSMTP.py.orig 2018-10-26 04:04:28 UTC
++++ iSMTP.py
+@@ -35,7 +35,7 @@ split_target = "\n " + colors.white + "=" * 23 + " sta
+
+ def help():
+ print banner
+- print " Usage: ./iSMTP.py <OPTIONS>\n"
++ print " Usage: ismtp <OPTIONS>\n"
+ print colors.red + " Required:\n" + colors.normal
+ print "\t-f <import file>\tImports a list of SMTP servers for testing.\n\t\t\t\t(Cannot use with '-h'.)"
+ print "\t-h <host>\t\tThe target IP and port (IP:port).\n\t\t\t\t(Cannot use with '-f'.)"
diff --git a/security/ismtp/pkg-descr b/security/ismtp/pkg-descr
new file mode 100644
index 000000000000..c901eb7c3620
--- /dev/null
+++ b/security/ismtp/pkg-descr
@@ -0,0 +1,5 @@
+SMTP user enumeration (RCPT TO and VRFY), internal spoofing, and open relay. A
+tool that tested for all three and with great flexibility. iSMTP does just
+that, making it much easier to knock that process out of the way.
+
+WWW: https://github.com/altjx/ipwn/tree/master/iSMTP