aboutsummaryrefslogtreecommitdiff
path: root/security/isnprober/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-30 18:15:59 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-30 18:15:59 +0000
commit21f7b02baad2150748e5fcd50c4b798c650974f5 (patch)
treeda4a20c069d82a8322881b7927e1839a73a8d2fb /security/isnprober/Makefile
parent4f4e6ed97d245c3269c1cc6f8b1db329d618ebc0 (diff)
Notes
Diffstat (limited to 'security/isnprober/Makefile')
-rw-r--r--security/isnprober/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/isnprober/Makefile b/security/isnprober/Makefile
new file mode 100644
index 000000000000..ebf461462353
--- /dev/null
+++ b/security/isnprober/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: isnprober
+# Date created: 28/7/2006
+# Whom: Yonatan <onatan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isnprober
+PORTVERSION= 1.02
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.ubizen.com/tools/ \
+ ${MASTER_SITE_PACKETSTORM}
+MASTER_SITE_SUBDIR= UNIX/scanners
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= onatan@gmail.com
+COMMENT= PenTest tool for TCP Initial Sequence Numbers research
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>