aboutsummaryrefslogtreecommitdiff
path: root/security/john
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-05-04 08:26:22 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-05-04 08:26:22 +0000
commitf50511c6a5b6aad0d876c470cb718c5d3e05a426 (patch)
tree03804422e847d784c0bbaa41c60a297a24767835 /security/john
parent9d915a40035cb9fe38a07aba912ac9eed38887af (diff)
downloadports-f50511c6a5b6aad0d876c470cb718c5d3e05a426.tar.gz
ports-f50511c6a5b6aad0d876c470cb718c5d3e05a426.zip
Notes
Diffstat (limited to 'security/john')
-rw-r--r--security/john/Makefile16
-rw-r--r--security/john/distinfo6
-rw-r--r--security/john/files/patch-params.h20
3 files changed, 23 insertions, 19 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index d3a8224043ce..dafd824c3b13 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= john
-PORTVERSION= 1.7
-PORTREVISION= 1
+PORTVERSION= 1.7.0.2
CATEGORIES= security
-MASTER_SITES= http://www.openwall.com/john/d/ \
- ftp://ftp.ru.openwall.com/pub/projects/john/
+MASTER_SITES= http://www.openwall.com/john/f/ \
+ ftp://ftp.ru.openwall.com/pub/projects/john/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rainer.alves@gmail.com
COMMENT= Featureful Unix password cracker
DATAFILES= all.chr alnum.chr alpha.chr digits.chr lanman.chr password.lst
@@ -20,10 +19,11 @@ PORTDOCS= CHANGES CONFIG EXAMPLES EXTERNAL FAQ MODES OPTIONS README \
RULES CONTACT CREDITS
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_BZIP2= yes
.include <bsd.port.pre.mk>
-OSNAME= ${OPSYS:S/F/f/:S/N/n/:S/O/o/:S/B/b/:S/S/s/:S/D/d/}
+OSNAME= ${OPSYS:L}
ALL_TARGET= generic
.if ${ARCH} == "i386"
@@ -37,9 +37,9 @@ ALL_TARGET= ${OSNAME}-alpha
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$$JOHN|${DATADIR}|g' \
+ ${REINPLACE_CMD} -e 's|$$JOHN|${DATADIR}|g' \
${WRKDIR}/${DISTNAME}/run/john.conf
- @${REINPLACE_CMD} -e \
+ ${REINPLACE_CMD} -e \
's|%%PREFIX%%|${PREFIX}|g; s|%%DATADIR%%|${DATADIR}|g'\
${WRKSRC}/params.h
diff --git a/security/john/distinfo b/security/john/distinfo
index da202ccd75d6..6a1357e53c4d 100644
--- a/security/john/distinfo
+++ b/security/john/distinfo
@@ -1,3 +1,3 @@
-MD5 (john-1.7.tar.gz) = c8121c5304ad64c7d5893b1b8177ea53
-SHA256 (john-1.7.tar.gz) = 5fc569c95bcef92522f9cd81cdda01fcfabc4c2f226197ba108fa7fd5af07f3d
-SIZE (john-1.7.tar.gz) = 799235
+MD5 (john-1.7.0.2.tar.bz2) = 0a87dca1f149493fc087ea8a8b6ae5d5
+SHA256 (john-1.7.0.2.tar.bz2) = d97ce0595befc940187930ab8185e5503e2a200fbd795e07a6b1f304de408b38
+SIZE (john-1.7.0.2.tar.bz2) = 690516
diff --git a/security/john/files/patch-params.h b/security/john/files/patch-params.h
index f4984d7f84b1..97d6c5597b15 100644
--- a/security/john/files/patch-params.h
+++ b/security/john/files/patch-params.h
@@ -1,7 +1,7 @@
---- params.h.orig Mon Jan 9 15:33:18 2006
-+++ params.h Sat Feb 18 19:02:07 2006
-@@ -22,12 +22,12 @@
- * will probably want to set this to 1 for their builds of John.
+--- params.h.orig Sun Mar 19 20:34:15 2006
++++ params.h Wed May 3 14:45:51 2006
+@@ -49,15 +49,15 @@
+ * notes above.
*/
#ifndef JOHN_SYSTEMWIDE
-#define JOHN_SYSTEMWIDE 0
@@ -9,13 +9,17 @@
#endif
#if JOHN_SYSTEMWIDE
- #ifndef JOHN_SYSTEMWIDE_EXEC
+ #ifndef JOHN_SYSTEMWIDE_EXEC /* please refer to the notes above */
-#define JOHN_SYSTEMWIDE_EXEC "/usr/libexec/john"
+#define JOHN_SYSTEMWIDE_EXEC "%%PREFIX%%/bin/john"
#endif
#ifndef JOHN_SYSTEMWIDE_HOME
- #define JOHN_SYSTEMWIDE_HOME "/usr/share/john"
-@@ -74,8 +74,8 @@
+-#define JOHN_SYSTEMWIDE_HOME "/usr/share/john"
++#define JOHN_SYSTEMWIDE_HOME "%%DATADIR%%"
+ #endif
+ #define JOHN_PRIVATE_HOME "~/.john"
+ #endif
+@@ -101,8 +101,8 @@
/*
* File names.
*/
@@ -26,7 +30,7 @@
#if JOHN_SYSTEMWIDE
#define CFG_PRIVATE_FULL_NAME JOHN_PRIVATE_HOME "/john.conf"
#define CFG_PRIVATE_ALT_NAME JOHN_PRIVATE_HOME "/john.ini"
-@@ -89,7 +89,7 @@
+@@ -116,7 +116,7 @@
#endif
#define LOG_SUFFIX ".log"
#define RECOVERY_SUFFIX ".rec"