aboutsummaryrefslogtreecommitdiff
path: root/security/kdbx-viewer
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-10-04 14:32:16 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-10-04 14:32:16 +0000
commitc5804a640b13d0077176567ee44ba58b9fb72469 (patch)
tree795cfbc8f225d95686306391e8cd5f1c3f4db097 /security/kdbx-viewer
parent0657a15d0303d4fd0287d7343534e0d05df05a29 (diff)
downloadports-c5804a640b13d0077176567ee44ba58b9fb72469.tar.gz
ports-c5804a640b13d0077176567ee44ba58b9fb72469.zip
Notes
Diffstat (limited to 'security/kdbx-viewer')
-rw-r--r--security/kdbx-viewer/Makefile35
-rw-r--r--security/kdbx-viewer/distinfo3
-rw-r--r--security/kdbx-viewer/pkg-descr10
3 files changed, 48 insertions, 0 deletions
diff --git a/security/kdbx-viewer/Makefile b/security/kdbx-viewer/Makefile
new file mode 100644
index 000000000000..dc7be9cf21dc
--- /dev/null
+++ b/security/kdbx-viewer/Makefile
@@ -0,0 +1,35 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kdbx-viewer
+PORTVERSION= 0.0.1
+DISTVERSIONPREFIX=v
+CATEGORIES= security
+
+MAINTAINER= woodsb02@FreeBSD.org
+COMMENT= ncurses GUI and command-line tool for KeePass2 Database files
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libgcrypt.so:security/libgcrypt \
+ libstfl.so:devel/stfl
+
+USE_GITHUB= yes
+GH_ACCOUNT= max-weller
+
+USES= ncurses
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_FILES= bin/kdbxviewer
+ALL_TARGET=
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS} ${LDFLAGS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/kdbxviewer ${STAGEDIR}${PREFIX}/bin/
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/kdbxviewer
+
+.include <bsd.port.mk>
diff --git a/security/kdbx-viewer/distinfo b/security/kdbx-viewer/distinfo
new file mode 100644
index 000000000000..789bb22447f9
--- /dev/null
+++ b/security/kdbx-viewer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475588279
+SHA256 (max-weller-kdbx-viewer-v0.0.1_GH0.tar.gz) = 9898385de015dc24fbe7137683c42a171438354312d05aec5a6d9e50ab6ebb9b
+SIZE (max-weller-kdbx-viewer-v0.0.1_GH0.tar.gz) = 142777
diff --git a/security/kdbx-viewer/pkg-descr b/security/kdbx-viewer/pkg-descr
new file mode 100644
index 000000000000..b098530d1e38
--- /dev/null
+++ b/security/kdbx-viewer/pkg-descr
@@ -0,0 +1,10 @@
+Command-line tool written in C for KeePass2 Database files (kdbx).
+It works completely read-only at the moment.
+
+Features:
+- ncurses GUI to browse and view password database
+- Dump raw, decrypted XML content with obscured passwords
+- Display tree structure with de-obscured (=readable) passwords
+- Get tab-separated (TSV/CSV) password list
+
+WWW: https://max-weller.github.io/kdbx-viewer/