aboutsummaryrefslogtreecommitdiff
path: root/security/keepassxc
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-05-09 09:26:04 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-05-09 09:26:04 +0000
commit417dd43ee2374e4076a877c8c56c250036c8c898 (patch)
tree9f30dc3bd7e4a928ecc928c1311685eda09f930a /security/keepassxc
parent92c986ad93befdcd359c38c424c26ffbaa7828bc (diff)
downloadports-417dd43ee2374e4076a877c8c56c250036c8c898.tar.gz
ports-417dd43ee2374e4076a877c8c56c250036c8c898.zip
Notes
Diffstat (limited to 'security/keepassxc')
-rw-r--r--security/keepassxc/Makefile26
-rw-r--r--security/keepassxc/distinfo6
-rw-r--r--security/keepassxc/pkg-plist2
3 files changed, 23 insertions, 11 deletions
diff --git a/security/keepassxc/Makefile b/security/keepassxc/Makefile
index 67a017b7994e..4a4075ba2f88 100644
--- a/security/keepassxc/Makefile
+++ b/security/keepassxc/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= keepassxc
-PORTVERSION= 2.1.3
-PORTREVISION= 1
+PORTVERSION= 2.1.4
CATEGORIES= security
MAINTAINER= melanhit@gmail.com
@@ -22,17 +21,30 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
CONFLICTS_INSTALL= keepassx-0.* keepassx2-* keepassx-*
-USES= cmake compiler:c++11-lib desktop-file-utils shared-mime-info
+USES= cmake:outsource compiler:c++11-lib desktop-file-utils shared-mime-info
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_QT5= buildtools_build concurrent core dbus gui linguisttools network \
- qmake_build testlib widgets x11extras
-USE_XORG= ice inputproto sm x11 xcursor xext xfixes xi xrandr xrender \
- xt xtst
+ qmake_build testlib widgets
+USE_XORG= ice inputproto sm x11 xcursor xext xfixes xrandr xrender xt
USE_GITHUB= yes
GH_ACCOUNT= keepassxreboot
-CMAKE_ARGS+= -DZLIB_SUPPORTS_GZIP:BOOL=ON -DWITH_XC_AUTOTYPE=ON -DWITH_XC_HTTP=ON
+CMAKE_ARGS+= -DZLIB_SUPPORTS_GZIP:BOOL=ON
+
+OPTIONS_DEFINE= AUTOTYPE HTTP TEST
+OPTIONS_DEFAULT= AUTOTYPE HTTP
+OPTIONS_SUB= yes
+
+AUTOTYPE_CMAKE_BOOL= WITH_XC_AUTOTYPE
+AUTOTYPE_DESC= Auto-type passwords in input fields
+AUTOTYPE_USE= QT5=x11extras XORG=xi,xtst
+
+HTTP_CMAKE_BOOL= WITH_XC_HTTP
+HTTP_DESC= KeePassHTTP support for ChromeIPass and PassIFox
+
+TEST_CMAKE_BOOL= WITH_TESTS WITH_GUI_TESTS
+TEST_TEST_TARGET= test
.include <bsd.port.mk>
diff --git a/security/keepassxc/distinfo b/security/keepassxc/distinfo
index cad2359daf63..8af133ce0838 100644
--- a/security/keepassxc/distinfo
+++ b/security/keepassxc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1488819301
-SHA256 (keepassxreboot-keepassxc-2.1.3_GH0.tar.gz) = 9cfdcb519127197e4b35837160729a3f38c34771f869249b03fa88a8104fb0e4
-SIZE (keepassxreboot-keepassxc-2.1.3_GH0.tar.gz) = 3329237
+TIMESTAMP = 1491852798
+SHA256 (keepassxreboot-keepassxc-2.1.4_GH0.tar.gz) = 40a990dbcf442eb3cad99452b58ffd36e5855b39e78f213ea20e99fbc7876701
+SIZE (keepassxreboot-keepassxc-2.1.4_GH0.tar.gz) = 3345520
diff --git a/security/keepassxc/pkg-plist b/security/keepassxc/pkg-plist
index 50ef04407ac9..bf2d8ed8bc59 100644
--- a/security/keepassxc/pkg-plist
+++ b/security/keepassxc/pkg-plist
@@ -1,5 +1,5 @@
bin/keepassxc
-lib/keepassxc/libkeepassx-autotype-xcb.so
+%%AUTOTYPE%%lib/keepassxc/libkeepassx-autotype-xcb.so
share/applications/keepassxc.desktop
share/icons/hicolor/128x128/apps/keepassxc-dark.png
share/icons/hicolor/128x128/apps/keepassxc-locked.png