aboutsummaryrefslogtreecommitdiff
path: root/security/klee
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /security/klee
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'security/klee')
-rw-r--r--security/klee/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/klee/Makefile b/security/klee/Makefile
index e11f60b454b0..f869b9de6b2b 100644
--- a/security/klee/Makefile
+++ b/security/klee/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= llvm-config${LLVM_VERSION}:devel/llvm${LLVM_VERSION} \
LLVM_VERSION= 38 # the latest llvm version that the master branch (79ac709) currently supports
-USES= cmake:outsource localbase pkgconfig python:run shebangfix
+USES= cmake localbase pkgconfig python:run shebangfix
USE_GITHUB= yes
SHEBANG_FILES= tools/klee-stats/klee-stats tools/ktest-tool/ktest-tool
USE_LDCONFIG= yes