aboutsummaryrefslogtreecommitdiff
path: root/security/knock
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2013-01-20 18:28:49 +0000
committerSofian Brabez <sbz@FreeBSD.org>2013-01-20 18:28:49 +0000
commit339e3a3a75ca5829e6cbd7c60984d8ba389b2e3d (patch)
tree24732718bf229c68e5f33a52ebc6146d9c4e49d2 /security/knock
parentc3e53501a76e7f406ae6f3a43a745e1041b31316 (diff)
downloadports-339e3a3a75ca5829e6cbd7c60984d8ba389b2e3d.tar.gz
ports-339e3a3a75ca5829e6cbd7c60984d8ba389b2e3d.zip
Notes
Diffstat (limited to 'security/knock')
-rw-r--r--security/knock/Makefile35
-rw-r--r--security/knock/pkg-descr2
2 files changed, 18 insertions, 19 deletions
diff --git a/security/knock/Makefile b/security/knock/Makefile
index 2d51815a7ed3..cb1c1399ee53 100644
--- a/security/knock/Makefile
+++ b/security/knock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: knock
-# Date Created: 2006-03-17
-# Whom: Shaun Amott <shaun@inerd.com>
-#
+# Created by: Shaun Amott <shaun@inerd.com>
# $FreeBSD$
-#
PORTNAME= knock
PORTVERSION= 0.5
@@ -11,10 +7,10 @@ PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.zeroflux.org/proj/knock/files/ \
- ${MASTER_SITE_LOCAL:S,%SUBDIR%,sbz,}
+ LOCAL/sbz
MAINTAINER= sbz@FreeBSD.org
-COMMENT= A flexible port-knocking server and client
+COMMENT= Flexible port-knocking server and client
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -25,25 +21,28 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS= SERVER "Install knockd server" on \
- CLIENT "Install knock client" on
+OPTIONS_DEFINE= CLIENT SERVER
+OPTIONS_DEFAULT= CLIENT SERVER
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SERVER)
+CLIENT_DESC= Install knock client
+SERVER_DESC= Install knockd server
+
+.if ${PORT_OPTIONS:MSERVER}
MAN1= knockd.1
USE_RC_SUBR= knockd
PLIST_FILES+= bin/knockd
PLIST_FILES+= etc/knockd.conf.sample
.endif
-.if defined(WITH_CLIENT)
+.if ${PORT_OPTIONS:MCLIENT}
MAN1+= knock.1
PLIST_FILES+= bin/knock
.endif
pre-configure:
-.if defined(WITHOUT_SERVER) && defined(WITHOUT_CLIENT)
+.if ${PORT_OPTIONS:MSERVER} && ${PORT_OPTIONS:MCLIENT}
IGNORE= at least one component must be selected for installation
.endif
@@ -60,22 +59,22 @@ post-patch:
${WRKSRC}/src/knock.c
do-install:
-.if defined(WITH_SERVER)
+.if ${PORT_OPTIONS:MSERVER}
${INSTALL_PROGRAM} ${WRKSRC}/knockd ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/knockd.conf ${PREFIX}/etc/knockd.conf.sample
.endif
-.if defined(WITH_CLIENT)
+.if ${PORT_OPTIONS:MCLIENT}
${INSTALL_PROGRAM} ${WRKSRC}/knock ${PREFIX}/bin
.endif
post-install-script:
-.if defined(WITH_SERVER)
+.if ${PORT_OPTIONS:MSERVER}
${INSTALL_MAN} ${WRKSRC}/doc/knockd.1.in ${MAN1PREFIX}/man/man1/knockd.1
.endif
-.if defined(WITH_CLIENT)
+.if ${PORT_OPTIONS:MCLIENT}
${INSTALL_MAN} ${WRKSRC}/doc/knock.1.in ${MAN1PREFIX}/man/man1/knock.1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/knock/pkg-descr b/security/knock/pkg-descr
index 5579491bf4bf..03879492a5cb 100644
--- a/security/knock/pkg-descr
+++ b/security/knock/pkg-descr
@@ -6,6 +6,6 @@ port on the server. This port need not be open -- since knockd listens
at the link-layer level, it sees all traffic even if it's destined for
a closed port. When the server detects a specific sequence of port-hits
port-hits, it runs a command defined in its configuration file. This
-can be used to open up holes in a firewall for quick access.
+can be used to open up holes in a firewall for quick access.
WWW: http://www.zeroflux.org/projects/knock