aboutsummaryrefslogtreecommitdiff
path: root/security/krb5-112
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2015-03-23 19:04:23 +0000
committerCy Schubert <cy@FreeBSD.org>2015-03-23 19:04:23 +0000
commit24695efe143802f17c8ddaf816ec19abff5cb2ce (patch)
treeb451268188f529b6fbf9890ca768308c88016379 /security/krb5-112
parent01f8b6d7d77351efd6f973eb1fac495cd0913543 (diff)
Fix build with libressl.
PR: 198749, 198750
Notes
Notes: svn path=/head/; revision=382023
Diffstat (limited to 'security/krb5-112')
-rw-r--r--security/krb5-112/Makefile1
-rw-r--r--security/krb5-112/files/patch-plugins__preauth__pkinit__pkinit_crypto_openssl.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/krb5-112/Makefile b/security/krb5-112/Makefile
index fd52f68cdcc7..8517c6783778 100644
--- a/security/krb5-112/Makefile
+++ b/security/krb5-112/Makefile
@@ -3,6 +3,7 @@
PORTNAME= krb5
PORTVERSION= 1.12.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PKGNAMESUFFIX= -112
diff --git a/security/krb5-112/files/patch-plugins__preauth__pkinit__pkinit_crypto_openssl.c b/security/krb5-112/files/patch-plugins__preauth__pkinit__pkinit_crypto_openssl.c
new file mode 100644
index 000000000000..4d202a7d1c45
--- /dev/null
+++ b/security/krb5-112/files/patch-plugins__preauth__pkinit__pkinit_crypto_openssl.c
@@ -0,0 +1,11 @@
+--- plugins/preauth/pkinit/pkinit_crypto_openssl.c.orig 2015-02-18 23:31:13.000000000 +0100
++++ plugins/preauth/pkinit/pkinit_crypto_openssl.c 2015-02-28 22:05:52.151654774 +0100
+@@ -172,7 +172,7 @@
+ pkinit_pkcs11_code_to_text(int err);
+
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L && !defined(OPENSSL_NO_CMS)
+ /* Use CMS support present in OpenSSL 1.0 and later. */
+ #include <openssl/cms.h>
+ #define pkinit_CMS_get0_content_signed(_cms) CMS_get0_content(_cms)