aboutsummaryrefslogtreecommitdiff
path: root/security/krb5-114
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2018-06-19 06:51:55 +0000
committerCy Schubert <cy@FreeBSD.org>2018-06-19 06:51:55 +0000
commit2946336f3cfa198a3f30e7f9db698b271e12bb8e (patch)
tree58c7a899e93c37fc58f1f8f6ebaca09194592286 /security/krb5-114
parent6ff5f18d040799c2e56adca450ca522295f5b890 (diff)
downloadports-2946336f3cfa198a3f30e7f9db698b271e12bb8e.tar.gz
ports-2946336f3cfa198a3f30e7f9db698b271e12bb8e.zip
Notes
Diffstat (limited to 'security/krb5-114')
-rw-r--r--security/krb5-114/Makefile2
-rw-r--r--security/krb5-114/files/patch-include_krb5_krb5.hin74
2 files changed, 75 insertions, 1 deletions
diff --git a/security/krb5-114/Makefile b/security/krb5-114/Makefile
index cd204ca85d12..f60f2fdcefe5 100644
--- a/security/krb5-114/Makefile
+++ b/security/krb5-114/Makefile
@@ -3,7 +3,7 @@
PORTNAME= krb5
PORTVERSION= 1.14.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
.if !defined(MASTERDIR)
diff --git a/security/krb5-114/files/patch-include_krb5_krb5.hin b/security/krb5-114/files/patch-include_krb5_krb5.hin
new file mode 100644
index 000000000000..d5a1ffc0ee26
--- /dev/null
+++ b/security/krb5-114/files/patch-include_krb5_krb5.hin
@@ -0,0 +1,74 @@
+--- include/krb5/krb5.hin.orig 2017-09-25 09:29:00.000000000 -0700
++++ include/krb5/krb5.hin 2018-06-18 22:55:26.074018000 -0700
+@@ -3542,7 +3542,7 @@
+ */
+ krb5_error_code KRB5_CALLCONV
+ krb5_unparse_name(krb5_context context, krb5_const_principal principal,
+- register char **name);
++ char **name);
+
+ /**
+ * Convert krb5_principal structure to string and length.
+@@ -4364,7 +4364,7 @@
+ */
+ krb5_error_code KRB5_CALLCONV_WRONG
+ krb5_principal2salt(krb5_context context,
+- register krb5_const_principal pr, krb5_data *ret);
++ krb5_const_principal pr, krb5_data *ret);
+ /* librc.spec--see rcache.h */
+
+ /* libcc.spec */
+@@ -4705,7 +4705,7 @@
+ * This function frees the contents of @a val and the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_error(krb5_context context, register krb5_error *val);
++krb5_free_error(krb5_context context, krb5_error *val);
+
+ /**
+ * Free a krb5_creds structure.
+@@ -4738,7 +4738,7 @@
+ * This function frees the contents of @a val and the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_checksum(krb5_context context, register krb5_checksum *val);
++krb5_free_checksum(krb5_context context, krb5_checksum *val);
+
+ /**
+ * Free the contents of a krb5_checksum structure.
+@@ -4749,7 +4749,7 @@
+ * This function frees the contents of @a val, but not the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_checksum_contents(krb5_context context, register krb5_checksum *val);
++krb5_free_checksum_contents(krb5_context context, krb5_checksum *val);
+
+ /**
+ * Free a krb5_keyblock structure.
+@@ -4760,7 +4760,7 @@
+ * This function frees the contents of @a val and the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_keyblock(krb5_context context, register krb5_keyblock *val);
++krb5_free_keyblock(krb5_context context, krb5_keyblock *val);
+
+ /**
+ * Free the contents of a krb5_keyblock structure.
+@@ -4771,7 +4771,7 @@
+ * This function frees the contents of @a key, but not the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_keyblock_contents(krb5_context context, register krb5_keyblock *key);
++krb5_free_keyblock_contents(krb5_context context, krb5_keyblock *key);
+
+ /**
+ * Free a krb5_ap_rep_enc_part structure.
+@@ -4887,7 +4887,7 @@
+ * Kerberos error codes
+ */
+ krb5_error_code KRB5_CALLCONV
+-krb5_timeofday(krb5_context context, register krb5_timestamp *timeret);
++krb5_timeofday(krb5_context context, krb5_timestamp *timeret);
+
+ /**
+ * Check if a timestamp is within the allowed clock skew of the current time.