aboutsummaryrefslogtreecommitdiff
path: root/security/krb5-appl/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2003-11-08 23:08:25 +0000
committerCy Schubert <cy@FreeBSD.org>2003-11-08 23:08:25 +0000
commitdf1d57b040c80841cb975726e64d5caa5a66872e (patch)
treeb2975df4504c6ab02c0fbd245c502b28b1acdd4a /security/krb5-appl/Makefile
parent4aff1bd3c521b2ba83e2e334420822a1c5dd674d (diff)
downloadports-df1d57b040c80841cb975726e64d5caa5a66872e.tar.gz
ports-df1d57b040c80841cb975726e64d5caa5a66872e.zip
Notes
Diffstat (limited to 'security/krb5-appl/Makefile')
-rw-r--r--security/krb5-appl/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 9e2855ef5821..99e0971dae71 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= security
# USE_MIT_TARBALL tells the port that the user has fetched the source
# directly from MIT rather than the default crypto-publish.org.
@@ -23,11 +24,10 @@ EXTRACT_SUFX= .tar.gz
MAINTAINER= cy@FreeBSD.org
COMMENT= An authentication system developed at MIT, successor to Kerberos IV
-BROKEN= "Does not build on 4.x, broken pkg-plist on 5.x; will be removed after Feb 2"
-
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
KERBEROSV_URL= http://web.mit.edu/network/kerberos-form.html
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
INSTALLS_SHLIB= yes
@@ -57,14 +57,15 @@ INFO_FILES= krb425.info krb5-admin.info krb5-admin.info-1 \
MAN1= krb5-send-pr.1 kpasswd.1 v5passwd.1 klist.1 kinit.1 \
kdestroy.1 ksu.1 sclient.1 rsh.1 rcp.1 rlogin.1 \
- ftp.1 telnet.1 kerberos.1 kvno.1
+ ftp.1 telnet.1 kerberos.1 kvno.1 compile_et.1
.if defined(KRB5_KRB4_COMPAT) && ${KRB5_KRB4_COMPAT} != "NO"
MAN1+= v4rcp.1
.endif
MAN5= kdc.conf.5 krb5.conf.5 .k5login.5
MAN8= krb5kdc.8 kadmin.8 kadmin.local.8 kdb5_util.8 \
ktutil.8 kadmind.8 kprop.8 kpropd.8 sserver.8 \
- kshd.8 klogind.8 login.krb5.8 ftpd.8 telnetd.8
+ kshd.8 klogind.8 login.krb5.8 ftpd.8 telnetd.8 \
+ k5srvutil.8
WRKSRC= ${WRKDIR}/${DISTNAME}/src
@@ -73,6 +74,8 @@ HTML_DOC_DIR= ${WRKDIR}/${DISTNAME}/doc
HTML_DOCS= admin.html user-guide.html install.html
HTML_OUTDIRS= krb5-admin krb5-install
+.include <bsd.port.pre.mk>
+
.if defined(USE_MIT_TARBALL) && ${USE_MIT_TARBALL} == "YES"
do-fetch:
@if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
@@ -102,6 +105,15 @@ post-extract:
.endif
.endif
+post-patch:
+.if ${OSVERSION} >= 500000
+ @${REINPLACE_CMD} -e '1s,^#!\/usr\/athena,#!${LOCALBASE},' \
+ ${WRKSRC}/../doc/man2html
+.else
+ @${REINPLACE_CMD} -e '1s,^#!\/usr\/athena,#!\/usr,' \
+ ${WRKSRC}/../doc/man2html
+.endif
+
pre-build:
.if !defined(KRB5_KRB4_COMPAT)
@${ECHO} "------------------------------------------------------"
@@ -118,8 +130,6 @@ post-build:
${MAKE} ${HTML_DOCS})
.endif
-.include <bsd.port.pre.mk>
-
post-install:
# html documentation
.if defined(WANT_HTML) && ${WANT_HTML} == "YES"