aboutsummaryrefslogtreecommitdiff
path: root/security/krb5/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-04-06 07:41:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-04-06 07:41:20 +0000
commitab747f70f6eb9c94aa7a29efc3110fcbb0a11eda (patch)
tree02622c0314a126be4c61e4c7ca829daa5ecb83de /security/krb5/Makefile
parentb99358be35ac1dd0305d691c79ca8848fc0e598b (diff)
Notes
Diffstat (limited to 'security/krb5/Makefile')
-rw-r--r--security/krb5/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index a69707a0f5a6..77f1c3e6769b 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
@@ -24,7 +24,6 @@ CONFLICTS= heimdal-[0-9]* srp-[0-9]*
LATEST_LINK= ${PORTNAME}-19
KERBEROSV_URL= http://web.mit.edu/kerberos/
-USE_OPENSSL= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
@@ -47,16 +46,31 @@ LDFLAGS+= -rpath=${KRB5_HOME}/lib
.endif
.include <bsd.port.pre.mk>
+
.if defined(WITH_DNS_FOR_REALM)
CONFIGURE_ARGS+= --enable-dns-for-realm
.endif
+USE_OPENSSL= yes
+
.if defined(WITH_KRB5_DOC)
BUILD_DEPENDS+= texi2dvi:${PORTSDIR}/print/texinfo \
dvips:${PORTSDIR}/print/dvipsk-tetex
INFO= krb5-admin krb5-install krb5-user
+
+# pointyhat kludge - tetex drags in port-OpenSSL on 7.X, but only as a build
+# dependency. Yet this triggers autodetection code in bsd.openssl.mk and
+# OpenSSL dependency is registered with the resulting package, creating a
+# discord between INDEX and actual package. Work around by explicitly recording
+# the dependency in a way that INDEX build will see.
+.if ${OSVERSION} < 800000
+WITH_OPENSSL_PORT= yes
+.endif
+
.endif
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+
MAN1= k5srvutil.1 kadmin.1 krb5-send-pr.1 krb5-config.1 \
kpasswd.1 klist.1 kinit.1 kdestroy.1 ksu.1 ktutil.1 \
sclient.1 kerberos.1 kvno.1 compile_et.1