aboutsummaryrefslogtreecommitdiff
path: root/security/labrea/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-06-14 03:53:27 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-06-14 03:53:27 +0000
commit3eb9ccd2ab7ea4fc61bb549999e21f318ede259d (patch)
tree9df5480050e8fef40f57e5880ee15ae0c9d288a6 /security/labrea/Makefile
parent45cd4d0fd1a0254828fe3eda4bb8a7755d4c4698 (diff)
Notes
Diffstat (limited to 'security/labrea/Makefile')
-rw-r--r--security/labrea/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/security/labrea/Makefile b/security/labrea/Makefile
index b2f34edc8927..51f9271ce104 100644
--- a/security/labrea/Makefile
+++ b/security/labrea/Makefile
@@ -6,29 +6,26 @@
##
PORTNAME= LaBrea
-PORTVERSION= 2.3
+PORTVERSION= 2.4
CATEGORIES= security
MASTER_SITES= http://freebsd.rogness.net/ports/labrea/
-DISTNAME= LaBrea${PORTVERSION:S/./_/g}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/g}
EXTRACT_SUFX= .tgz
MAINTAINER= nick@rogness.net
-COMMENT= Defense mechanism against CodeRed
+COMMENT= Security tarpit defense tool
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
-WRKSRC= ${WRKDIR}/LaBrea
-USE_REINPLACE= yes
-
-MAKE_ARGS= CC="${CC}" OPTFLAGS="${CFLAGS}"
+ALL_TARGET= ${PORTNAME}
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/LaBrea
- ${INSTALL_MAN} ${WRKSRC}/LaBrea.README ${PREFIX}/share/doc/LaBrea
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/LaBrea.README ${DOCSDIR}
@echo "******************************************"
@echo "You will need to read the LaBrea.README in"
- @echo "${PREFIX}/share/doc/LaBrea"
+ @echo "${DOCSDIR}"
@echo "Before your run this!!"
@echo "******************************************"
@echo .