aboutsummaryrefslogtreecommitdiff
path: root/security/lastpass-cli
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-04 17:11:05 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-04 17:11:05 +0000
commit79a5b4f69690bb5845b8078e256c075b849d0346 (patch)
treef4a5dee43b92408a88fe04ba5a6c2af6ab12629e /security/lastpass-cli
parentcea8b47d653ef9fcf0148d0f5b72e749dc52c6e8 (diff)
Notes
Diffstat (limited to 'security/lastpass-cli')
-rw-r--r--security/lastpass-cli/Makefile49
-rw-r--r--security/lastpass-cli/distinfo2
-rw-r--r--security/lastpass-cli/pkg-descr4
-rw-r--r--security/lastpass-cli/pkg-message33
4 files changed, 88 insertions, 0 deletions
diff --git a/security/lastpass-cli/Makefile b/security/lastpass-cli/Makefile
new file mode 100644
index 000000000000..480a97ebe312
--- /dev/null
+++ b/security/lastpass-cli/Makefile
@@ -0,0 +1,49 @@
+# Created by: Thomas Hurst <tom@hur.st>
+# $FreeBSD$
+
+PORTNAME= lastpass-cli
+PORTVERSION= 0.3.0.20141031
+CATEGORIES= security
+MASTER_SITES= GH
+
+MAINTAINER= tom@hur.st
+COMMENT= LastPass command line interface tool
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+USES= gmake pkgconfig
+USE_GNOME= libxml2
+USE_OPENSSL= yes
+
+USE_GITHUB= YES
+GH_ACCOUNT= lastpass
+GH_PROJECT= lastpass-cli
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 8993a4e
+
+PLIST_FILES= bin/lpass
+MAKE_ENV+= MANDIR=${MANPREFIX}/man
+
+OPTIONS_DEFINE= MANPAGES PINENTRY XCLIP XSEL
+OPTIONS_DEFAULT= MANPAGES
+PINENTRY_DESC= Use pinentry for password entry
+XCLIP_DESC= Use xclip for interacting with X11 clipboard
+XSEL_DESC= Use xsel for interacting with X11 clipboard
+
+MANPAGES_BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ xmlto:${PORTSDIR}/textproc/xmlto
+MANPAGES_ALL_TARGET= all doc-man
+MANPAGES_INSTALL_TARGET=install install-doc
+MANPAGES_PLIST_FILES= ${MANPREFIX}/man/man1/lpass.1.gz
+
+PINENTRY_RUN_DEPENDS= pinentry:${PORTSDIR}/security/pinentry
+XCLIP_RUN_DEPENDS= xclip:${PORTSDIR}/x11/xclip
+XSEL_RUN_DEPENDS= xsel:${PORTSDIR}/x11/xsel
+
+post-extract:
+ @${REINPLACE_CMD} -e 's/-Wno-language-extension-token//g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/lastpass-cli/distinfo b/security/lastpass-cli/distinfo
new file mode 100644
index 000000000000..44810bc4bc17
--- /dev/null
+++ b/security/lastpass-cli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lastpass-cli-0.3.0.20141031.tar.gz) = b7297875991857a36b7fbce46822c62836e91a4cb6f044ba6f123e576eb39e38
+SIZE (lastpass-cli-0.3.0.20141031.tar.gz) = 57243
diff --git a/security/lastpass-cli/pkg-descr b/security/lastpass-cli/pkg-descr
new file mode 100644
index 000000000000..840065ac0a42
--- /dev/null
+++ b/security/lastpass-cli/pkg-descr
@@ -0,0 +1,4 @@
+lastpass-cli is an open-source command-line interface to the popular
+LastPass password management service.
+
+WWW: https://lastpass.com/
diff --git a/security/lastpass-cli/pkg-message b/security/lastpass-cli/pkg-message
new file mode 100644
index 000000000000..b7a4eb0966f5
--- /dev/null
+++ b/security/lastpass-cli/pkg-message
@@ -0,0 +1,33 @@
+===============================================================================
+Important security considerations
+===============================================================================
+
+Before using the 'edit' subcommand interactively, it's recommended to set the
+SECURE_TMPDIR environment variable to a location that isn't written to disk,
+such as a tmpfs mount, ideally using encrypted swap:
+
+ https://www.freebsd.org/doc/handbook/swap-encrypting.html
+
+Also keep in mind your editor may create temporary files and backups in other
+locations - consider disabling these features for files matching the pattern
+lpass.* or within your $SECURE_TMPDIR. For example, with vim:
+
+ autocmd BufRead lpass.* setlocal noundofile nowritebackup noswapfile
+
+
+===============================================================================
+Using OpenSSL from ports
+===============================================================================
+
+If you're using security/openssl, ensure ftp/curl is configured with the
+HEIMDAL_PORT option to avoid linking to two different OpenSSL libraries.
+
+
+===============================================================================
+Other steps
+===============================================================================
+
+lpass requires /proc to be mounted for correct operation. To enable it add
+the following to /etc/fstab and run 'mount /proc':
+
+ proc /proc procfs rw 0 0