aboutsummaryrefslogtreecommitdiff
path: root/security/libecc/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-07-05 08:37:10 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-07-05 08:37:10 +0000
commitf4129178764bbcfc38945106b7ea7562e34cc26e (patch)
tree86789acef2364d0a141901250484871993595bcb /security/libecc/Makefile
parent8a6eb345cd7352a139550efeebc5f3d431cb0ee4 (diff)
downloadports-f4129178764bbcfc38945106b7ea7562e34cc26e.tar.gz
ports-f4129178764bbcfc38945106b7ea7562e34cc26e.zip
Notes
Diffstat (limited to 'security/libecc/Makefile')
-rw-r--r--security/libecc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/libecc/Makefile b/security/libecc/Makefile
index bd61797131e6..7e9fcb165964 100644
--- a/security/libecc/Makefile
+++ b/security/libecc/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libecc
-PORTVERSION= 0.3.0
+PORTVERSION= 0.11.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,10 +15,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Elliptic Curve Library
-USE_GCC= 3.3
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+
+USE_GCC= 3.3+
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include"
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 501103