aboutsummaryrefslogtreecommitdiff
path: root/security/libfwbuilder-devel/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-05-21 17:15:32 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-05-21 17:15:32 +0000
commit7d18490f876afaf7b7aac971b3a56a1636d6cc4a (patch)
tree28009e778454f865b546b2c37737ced4849d1d66 /security/libfwbuilder-devel/Makefile
parentc746db40972de12f7b75bbcda3676bdcec500518 (diff)
downloadports-7d18490f876afaf7b7aac971b3a56a1636d6cc4a.tar.gz
ports-7d18490f876afaf7b7aac971b3a56a1636d6cc4a.zip
Notes
Diffstat (limited to 'security/libfwbuilder-devel/Makefile')
-rw-r--r--security/libfwbuilder-devel/Makefile31
1 files changed, 19 insertions, 12 deletions
diff --git a/security/libfwbuilder-devel/Makefile b/security/libfwbuilder-devel/Makefile
index 5908f3361e38..4715c5f932c6 100644
--- a/security/libfwbuilder-devel/Makefile
+++ b/security/libfwbuilder-devel/Makefile
@@ -5,28 +5,35 @@
# $FreeBSD$
PORTNAME= libfwbuilder
-PORTVERSION= 0.10.7
+PORTVERSION= 1.0.0
+PORTREVISION= RC2
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= fwbuilder
+MASTER_SITES= ftp://downloads.fwbuilder.org/pub/fwbuilder/nightly_builds/current/ \
+ ${MASTER_SITE_SOURCEFORGE}/fwbuilder/
MAINTAINER= devnull@uptsoft.com
COMMENT= Firewall Builder API
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ automake:${PORTSDIR}/devel/automake
+
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
xslt.1:${PORTSDIR}/textproc/libxslt \
- sigc.1:${PORTSDIR}/devel/libsigc++
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
+ crypto.3:${PORTSDIR}/security/openssl \
+ netsnmp.5:${PORTSDIR}/net/net-snmp \
+ isc.1:${PORTSDIR}/net/bind9
+CONFIGURE_SCRIPT= autogen.sh
+CONFIGURE_ARGS=
+USE_AUTOCONF= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_GNOME= gtk12
+USE_GTK= no
INSTALLS_SHLIB= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-.include <bsd.port.post.mk>
+post-patch:
+ @${ECHO_CMD} "===! Running aclocal"
+ @(cd ${WRKSRC}; aclocal)
+
+.include <bsd.port.mk>