aboutsummaryrefslogtreecommitdiff
path: root/security/libgcrypt/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-07-03 11:39:40 +0000
committerSteve Wills <swills@FreeBSD.org>2011-07-03 11:39:40 +0000
commitfbb7343c346a1f20491ae407f8878480a44f83a2 (patch)
tree7a56c8831067a5a847da44a3f22ded66ecfe9e36 /security/libgcrypt/Makefile
parent276b84930433378d51844bddc197bd3ac701c9b8 (diff)
downloadports-fbb7343c346a1f20491ae407f8878480a44f83a2.tar.gz
ports-fbb7343c346a1f20491ae407f8878480a44f83a2.zip
Notes
Diffstat (limited to 'security/libgcrypt/Makefile')
-rw-r--r--security/libgcrypt/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index cbf520b86b60..5d32be9f52ee 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libgcrypt
-PORTVERSION= 1.4.6
+PORTVERSION= 1.5.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -13,11 +13,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= umq@ueo.co.jp
COMMENT= General purpose crypto library based on code used in GnuPG
-LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
-
LICENSE= GPLv2 LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING ${WRKSRC}/COPYING.LIB
LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/COPYING ${WRKSRC}/COPYING.LIB
+
+LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
+
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
USE_CSTD= gnu89
@@ -33,6 +34,10 @@ INFO= gcrypt
.if ${ARCH} == "powerpc"
CONFIGURE_ARGS+= --disable-asm
+.elif ${ARCH} == "i386"
+.if (${OSVERSION} < 900033)
+CONFIGURE_ARGS+= --disable-aesni-support
+.endif
.endif
.if (${OSVERSION} < 700000)
CONFIGURE_ARGS+= --disable-padlock-support