aboutsummaryrefslogtreecommitdiff
path: root/security/libgcrypt
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2014-07-05 23:19:05 +0000
committerSean Bruno <sbruno@FreeBSD.org>2014-07-05 23:19:05 +0000
commit915a5e61569e00521893d8f04dd9748b3690a6ac (patch)
tree2cfa10374107eb6ea1741631457a4a418d91592b /security/libgcrypt
parentae3d4d861911dd3c420fb4801f0110e15ee028e6 (diff)
downloadports-915a5e61569e00521893d8f04dd9748b3690a6ac.tar.gz
ports-915a5e61569e00521893d8f04dd9748b3690a6ac.zip
Notes
Diffstat (limited to 'security/libgcrypt')
-rw-r--r--security/libgcrypt/Makefile5
-rw-r--r--security/libgcrypt/files/patch-mpi-longlong.h41
2 files changed, 40 insertions, 6 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 62341418a87e..ccb4ac8cc280 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgcrypt
PORTVERSION= 1.5.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -33,9 +33,6 @@ PORTDOCS= *
.if ${ARCH} == "powerpc"
CONFIGURE_ARGS+= --disable-asm
-.elif ${ARCH} == "armv6"
-USE_GCC= any
-
.elif ${ARCH} == "i386"
.if (${OSVERSION} < 900033)
CONFIGURE_ARGS+= --disable-aesni-support
diff --git a/security/libgcrypt/files/patch-mpi-longlong.h b/security/libgcrypt/files/patch-mpi-longlong.h
index a82c7188b0d5..cd50255bf223 100644
--- a/security/libgcrypt/files/patch-mpi-longlong.h
+++ b/security/libgcrypt/files/patch-mpi-longlong.h
@@ -1,5 +1,42 @@
---- ./mpi/longlong.h.orig 2010-02-22 19:04:43.000000000 +0900
-+++ ./mpi/longlong.h 2010-11-01 18:25:34.000000000 +0900
+--- ./mpi/longlong.h.orig 2013-07-25 09:10:04.000000000 +0000
++++ ./mpi/longlong.h 2014-06-09 18:53:59.000000000 +0000
+@@ -188,8 +188,8 @@
+ #define add_ssaaaa(sh, sl, ah, al, bh, bl) \
+ __asm__ ("adds %1, %4, %5\n" \
+ "adc %0, %2, %3" \
+- : "=r" ((USItype)(sh)), \
+- "=&r" ((USItype)(sl)) \
++ : "=r" ((sh)), \
++ "=&r" ((sl)) \
+ : "%r" ((USItype)(ah)), \
+ "rI" ((USItype)(bh)), \
+ "%r" ((USItype)(al)), \
+@@ -197,8 +197,8 @@
+ #define sub_ddmmss(sh, sl, ah, al, bh, bl) \
+ __asm__ ("subs %1, %4, %5\n" \
+ "sbc %0, %2, %3" \
+- : "=r" ((USItype)(sh)), \
+- "=&r" ((USItype)(sl)) \
++ : "=r" ((sh)), \
++ "=&r" ((sl)) \
+ : "r" ((USItype)(ah)), \
+ "rI" ((USItype)(bh)), \
+ "r" ((USItype)(al)), \
+@@ -225,10 +225,10 @@
+ : "r0", "r1", "r2")
+ #else
+ #define umul_ppmm(xh, xl, a, b) \
+- __asm__ ("%@ Inlined umul_ppmm\n" \
+- "umull %r1, %r0, %r2, %r3" \
+- : "=&r" ((USItype)(xh)), \
+- "=r" ((USItype)(xl)) \
++ __asm__ ( \
++ "umull %1, %0, %2, %3" \
++ : "=&r" ((xh)), \
++ "=r" ((xl)) \
+ : "r" ((USItype)(a)), \
+ "r" ((USItype)(b)) \
+ : "r0", "r1")
@@ -437,8 +437,8 @@
#define add_ssaaaa(sh, sl, ah, al, bh, bl) \
__asm__ ("addl %5,%1\n" \