aboutsummaryrefslogtreecommitdiff
path: root/security/libgcrypt
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-02-08 20:54:10 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-02-08 20:54:10 +0000
commit9905a1a10298a72fc6a03a12d1fb0f1feed4f44f (patch)
tree2bea0aec36adf993443a660cc3ddd015efa77157 /security/libgcrypt
parentd6ab3c6fcf9182cd175ff657a437c92ca2a752a3 (diff)
downloadports-9905a1a10298a72fc6a03a12d1fb0f1feed4f44f.tar.gz
ports-9905a1a10298a72fc6a03a12d1fb0f1feed4f44f.zip
Notes
Diffstat (limited to 'security/libgcrypt')
-rw-r--r--security/libgcrypt/Makefile4
-rw-r--r--security/libgcrypt/files/patch-cipher-Makefile.in23
-rw-r--r--security/libgcrypt/files/patch-cipher_salsa20.c61
-rw-r--r--security/libgcrypt/files/patch-git_f583228540
-rw-r--r--security/libgcrypt/files/patch-src_gcrypt.h.in20
5 files changed, 83 insertions, 65 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 19116bdaed1f..34786e7c8f03 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -2,11 +2,11 @@
PORTNAME= libgcrypt
PORTVERSION= 1.6.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= GNUPG
-MAINTAINER= cpm@fbsd.es
+MAINTAINER= cpm@FreeBSD.org
COMMENT= General purpose crypto library based on code used in GnuPG
LICENSE= GPLv2 LGPL21
diff --git a/security/libgcrypt/files/patch-cipher-Makefile.in b/security/libgcrypt/files/patch-cipher-Makefile.in
deleted file mode 100644
index 2862e3746666..000000000000
--- a/security/libgcrypt/files/patch-cipher-Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- cipher/Makefile.in.orig 2015-09-08 06:32:11 UTC
-+++ cipher/Makefile.in
-@@ -818,13 +818,19 @@ uninstall-am:
- tags tags-am uninstall uninstall-am
-
-
--# We need to lower the optimization for this module.
-+# We need to lower the optimization for these modules.
- tiger.o: $(srcdir)/tiger.c
- `echo $(COMPILE) -c $(srcdir)/tiger.c | $(o_flag_munging) `
-
- tiger.lo: $(srcdir)/tiger.c
- `echo $(LTCOMPILE) -c $(srcdir)/tiger.c | $(o_flag_munging) `
-
-+salsa20.o: $(srcdir)/salsa20.c
-+ `echo $(COMPILE) -c $(srcdir)/salsa20.c | $(o_flag_munging) `
-+
-+salsa20.lo: $(srcdir)/salsa20.c
-+ `echo $(LTCOMPILE) -c $(srcdir)/salsa20.c | $(o_flag_munging) `
-+
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/security/libgcrypt/files/patch-cipher_salsa20.c b/security/libgcrypt/files/patch-cipher_salsa20.c
new file mode 100644
index 000000000000..37c6537b1c87
--- /dev/null
+++ b/security/libgcrypt/files/patch-cipher_salsa20.c
@@ -0,0 +1,61 @@
+--- cipher/salsa20.c.orig 2016-02-03 17:12:14 UTC
++++ cipher/salsa20.c
+@@ -485,7 +485,8 @@ salsa20r12_encrypt_stream (void *context
+ static const char*
+ selftest (void)
+ {
+- SALSA20_context_t ctx;
++ byte ctxbuf[sizeof(SALSA20_context_t) + 15];
++ SALSA20_context_t *ctx;
+ byte scratch[8+1];
+ byte buf[256+64+4];
+ int i;
+@@ -502,32 +503,35 @@ selftest (void)
+ static const byte ciphertext_1[] =
+ { 0xE3, 0xBE, 0x8F, 0xDD, 0x8B, 0xEC, 0xA2, 0xE3};
+
+- salsa20_setkey (&ctx, key_1, sizeof key_1);
+- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
++ /* 16-byte alignment required for amd64 implementation. */
++ ctx = (SALSA20_context_t *)((uintptr_t)(ctxbuf + 15) & ~(uintptr_t)15);
++
++ salsa20_setkey (ctx, key_1, sizeof key_1);
++ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
+ scratch[8] = 0;
+- salsa20_encrypt_stream (&ctx, scratch, plaintext_1, sizeof plaintext_1);
++ salsa20_encrypt_stream (ctx, scratch, plaintext_1, sizeof plaintext_1);
+ if (memcmp (scratch, ciphertext_1, sizeof ciphertext_1))
+ return "Salsa20 encryption test 1 failed.";
+ if (scratch[8])
+ return "Salsa20 wrote too much.";
+- salsa20_setkey( &ctx, key_1, sizeof(key_1));
+- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
+- salsa20_encrypt_stream (&ctx, scratch, scratch, sizeof plaintext_1);
++ salsa20_setkey (ctx, key_1, sizeof(key_1));
++ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
++ salsa20_encrypt_stream (ctx, scratch, scratch, sizeof plaintext_1);
+ if (memcmp (scratch, plaintext_1, sizeof plaintext_1))
+ return "Salsa20 decryption test 1 failed.";
+
+ for (i = 0; i < sizeof buf; i++)
+ buf[i] = i;
+- salsa20_setkey (&ctx, key_1, sizeof key_1);
+- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
++ salsa20_setkey (ctx, key_1, sizeof key_1);
++ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
+ /*encrypt*/
+ salsa20_encrypt_stream (&ctx, buf, buf, sizeof buf);
+ /*decrypt*/
+- salsa20_setkey (&ctx, key_1, sizeof key_1);
+- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
+- salsa20_encrypt_stream (&ctx, buf, buf, 1);
+- salsa20_encrypt_stream (&ctx, buf+1, buf+1, (sizeof buf)-1-1);
+- salsa20_encrypt_stream (&ctx, buf+(sizeof buf)-1, buf+(sizeof buf)-1, 1);
++ salsa20_setkey (ctx, key_1, sizeof key_1);
++ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
++ salsa20_encrypt_stream (ctx, buf, buf, 1);
++ salsa20_encrypt_stream (ctx, buf+1, buf+1, (sizeof buf)-1-1);
++ salsa20_encrypt_stream (ctx, buf+(sizeof buf)-1, buf+(sizeof buf)-1, 1);
+ for (i = 0; i < sizeof buf; i++)
+ if (buf[i] != (byte)i)
+ return "Salsa20 encryption test 2 failed.";
diff --git a/security/libgcrypt/files/patch-git_f5832285 b/security/libgcrypt/files/patch-git_f5832285
deleted file mode 100644
index cc2b6d3b9aea..000000000000
--- a/security/libgcrypt/files/patch-git_f5832285
+++ /dev/null
@@ -1,40 +0,0 @@
-Fixes at least devel/ccrtp's build:
- In file included from ccrtp/crypto/gcrypt/gcrypthmac.cpp:23:
- /usr/local/include/gcrypt.h:509: error: comma at end of enumerator list
- /usr/local/include/gcrypt.h:1346: error: comma at end of enumerator list
-
-From: Werner Koch <wk@gnupg.org>
-Date: Thu, 19 Mar 2015 09:43:55 +0000 (+0100)
-Subject: Fix two pedantic warnings.
-X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commitdiff_plain;h=f5832285b0e420d77be1b8da10a1e1d86583b414
-
-Fix two pedantic warnings.
-
-* src/gcrypt.h.in (gcry_mpi_flag, gcry_mac_algos): Remove trailing
-comma.
---
-
-Reported-by: Opal Raava <opalraava@hushmail.com>
-Signed-off-by: Werner Koch <wk@gnupg.org>
----
-
---- src/gcrypt.h.in
-+++ src/gcrypt.h.in
-@@ -511,7 +511,7 @@ enum gcry_mpi_flag
- GCRYMPI_FLAG_USER1 = 0x0100,/* User flag 1. */
- GCRYMPI_FLAG_USER2 = 0x0200,/* User flag 2. */
- GCRYMPI_FLAG_USER3 = 0x0400,/* User flag 3. */
-- GCRYMPI_FLAG_USER4 = 0x0800,/* User flag 4. */
-+ GCRYMPI_FLAG_USER4 = 0x0800 /* User flag 4. */
- };
-
-
-@@ -1372,7 +1372,7 @@ enum gcry_mac_algos
- /* Flags used with the open function. */
- enum gcry_mac_flags
- {
-- GCRY_MAC_FLAG_SECURE = 1, /* Allocate all buffers in "secure" memory. */
-+ GCRY_MAC_FLAG_SECURE = 1 /* Allocate all buffers in "secure" memory. */
- };
-
- /* Create a MAC handle for algorithm ALGO. FLAGS may be given as an bitwise OR
diff --git a/security/libgcrypt/files/patch-src_gcrypt.h.in b/security/libgcrypt/files/patch-src_gcrypt.h.in
new file mode 100644
index 000000000000..65b4c5a886fd
--- /dev/null
+++ b/security/libgcrypt/files/patch-src_gcrypt.h.in
@@ -0,0 +1,20 @@
+--- src/gcrypt.h.in.orig 2015-09-07 12:05:57 UTC
++++ src/gcrypt.h.in
+@@ -506,7 +506,7 @@ enum gcry_mpi_flag
+ GCRYMPI_FLAG_USER1 = 0x0100,/* User flag 1. */
+ GCRYMPI_FLAG_USER2 = 0x0200,/* User flag 2. */
+ GCRYMPI_FLAG_USER3 = 0x0400,/* User flag 3. */
+- GCRYMPI_FLAG_USER4 = 0x0800,/* User flag 4. */
++ GCRYMPI_FLAG_USER4 = 0x0800 /* User flag 4. */
+ };
+
+
+@@ -1343,7 +1343,7 @@ enum gcry_mac_algos
+ /* Flags used with the open function. */
+ enum gcry_mac_flags
+ {
+- GCRY_MAC_FLAG_SECURE = 1, /* Allocate all buffers in "secure" memory. */
++ GCRY_MAC_FLAG_SECURE = 1 /* Allocate all buffers in "secure" memory. */
+ };
+
+ /* Create a MAC handle for algorithm ALGO. FLAGS may be given as an bitwise OR