aboutsummaryrefslogtreecommitdiff
path: root/security/libksba/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-03-27 19:03:02 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-03-27 19:03:02 +0000
commit496a75656ea2e6cff153a1ebac4361ebf0872705 (patch)
treedb3fe41f373dc632f3d9eabd124e066a006bf43f /security/libksba/Makefile
parentff61321e1e9cc34d011df24a354ca45ebf42efab (diff)
downloadports-496a75656ea2e6cff153a1ebac4361ebf0872705.tar.gz
ports-496a75656ea2e6cff153a1ebac4361ebf0872705.zip
Notes
Diffstat (limited to 'security/libksba/Makefile')
-rw-r--r--security/libksba/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/libksba/Makefile b/security/libksba/Makefile
index 704af3595eee..ec5b7a910e80 100644
--- a/security/libksba/Makefile
+++ b/security/libksba/Makefile
@@ -5,15 +5,17 @@
# $FreeBSD$
PORTNAME= libksba
-PORTVERSION= 1.1.0
+PORTVERSION= 1.2.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= KSBA is an X.509 Library
-BUILD_DEPENDS+= libgpg-error>=1.8:${PORTSDIR}/security/libgpg-error
+BUILD_DEPENDS+= libgpg-error>=1.10:${PORTSDIR}/security/libgpg-error
LIB_DEPENDS+= gpg-error.0:${PORTSDIR}/security/libgpg-error
USE_BZIP2= yes
@@ -24,4 +26,7 @@ USE_PERL5_BUILD=yes
INFO= ksba
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
+
.include <bsd.port.mk>