aboutsummaryrefslogtreecommitdiff
path: root/security/libparanoia/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-14 13:33:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-14 13:33:30 +0000
commit77ec90b79c536d9054bcfd31e9132c807500e84f (patch)
tree70a3a5ca213e8e68f81f139b858ede0d46ec26ac /security/libparanoia/Makefile
parent748f28b5fa9ed261380f08bb4012f82aa5ee5b69 (diff)
Notes
Diffstat (limited to 'security/libparanoia/Makefile')
-rw-r--r--security/libparanoia/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/security/libparanoia/Makefile b/security/libparanoia/Makefile
index f489f9c69458..dffac25024d1 100644
--- a/security/libparanoia/Makefile
+++ b/security/libparanoia/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= libparanoia
-PORTVERSION= 1.4
-PORTREVISION= 3
+PORTVERSION= 1.4.1
CATEGORIES= security
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
@@ -15,26 +14,20 @@ COMMENT= Safe (in the mean of stack smashing) reincarnation of strcpy et al
ONLY_FOR_ARCHS= i386
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
# this library depends on system-defined headers "SYS.h" and "DEFS.h"
# which may differ from release to release.
.if !exists(/usr/src/lib/libc)
-IGNORE= You need to have libc sources installed in /usr/src/lib/libc \
- before compiling.
+IGNORE= you need to have libc sources installed in /usr/src/lib/libc \
+ before compiling
.endif
.include <bsd.port.pre.mk>
-pre-patch:
- @${REINPLACE_CMD} -e 's|\(SIGSEGV\),\(getpid()\)|\2,\1|; \
- s|#include <varargs.h>||' \
+do-patch:
+ @${REINPLACE_CMD} -e 's|#include <varargs.h>||' \
${WRKSRC}/stentry.c
-.if ${OSVERSION} >= 500039
-post-patch:
- @(cd ${_DISTDIR};${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/vsnprintf-current.patch)
-.endif
-
.include <bsd.port.post.mk>