aboutsummaryrefslogtreecommitdiff
path: root/security/libprelude
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-09-29 23:44:51 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-09-29 23:44:51 +0000
commita8258e4503b62df12da75c88ea376d765643da0a (patch)
tree291192af47169655b50bfd426ae5d03b56607724 /security/libprelude
parented642c9ffbcde0c7246d6be17248e1ca614e7be1 (diff)
downloadports-a8258e4503b62df12da75c88ea376d765643da0a.tar.gz
ports-a8258e4503b62df12da75c88ea376d765643da0a.zip
Notes
Diffstat (limited to 'security/libprelude')
-rw-r--r--security/libprelude/Makefile21
-rw-r--r--security/libprelude/distinfo6
-rw-r--r--security/libprelude/files/patch-Makefile.in6
-rw-r--r--security/libprelude/files/patch-bindings_perl_Prelude.c14
-rw-r--r--security/libprelude/files/patch-libmissing_Makefile.in20
-rw-r--r--security/libprelude/pkg-plist60
6 files changed, 35 insertions, 92 deletions
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index 4d155b39e04a..cec825d525a9 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -4,11 +4,10 @@
# $FreeBSD$
PORTNAME= libprelude
-PORTVERSION= 0.9.17.2
-PORTREVISION= 1
+PORTVERSION= 0.9.20.2
CATEGORIES= security
-MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
- http://www.prelude-ids.org/download/releases/old/
+MASTER_SITES= http://www.prelude-ids.com/download/releases/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME} ${PORTNAME}/old
MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Framework library for Prelude NIDS
@@ -24,6 +23,7 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --localstatedir=/var
MAN1= prelude-admin.1
+PORTDOCS= *
.include <bsd.port.pre.mk>
@@ -38,9 +38,8 @@ PLIST_SUB+= WITH_PERL="@comment "
.if defined(WITH_PYTHON)
USE_PYTHON= 2.3+
-.include "${PORTSDIR}/Mk/bsd.python.mk"
CONFIGURE_ARGS+= --with-python
-PLIST_SUB+= WITH_PYTHON=""
+PLIST_SUB+= WITH_PYTHON="" PYTHON_VER=${PYTHON_VER}
.else
CONFIGURE_ARGS+= --without-python
PLIST_SUB+= WITH_PYTHON="@comment "
@@ -48,15 +47,19 @@ PLIST_SUB+= WITH_PYTHON="@comment "
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
+.endif
.if ${ARCH} == "sparc64"
BROKEN= Does not compile
.endif
post-install:
- @${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/docs/manpages/*.1 ${MAN1PREFIX}/man/man1/
+.endif
+
+ @${INSTALL_MAN} ${WRKSRC}/docs/manpages/*.1 ${MAN1PREFIX}/man/man1/
@if [ ! -f ${PREFIX}/etc/prelude/default/client.conf ]; then \
${CP} -p ${PREFIX}/etc/prelude/default/client.conf-dist \
@@ -78,6 +81,4 @@ post-install:
${PREFIX}/etc/prelude/default/tls.conf ; \
fi
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/libprelude/distinfo b/security/libprelude/distinfo
index 0fc4599104b6..ad3a563c3c5e 100644
--- a/security/libprelude/distinfo
+++ b/security/libprelude/distinfo
@@ -1,3 +1,3 @@
-MD5 (libprelude-0.9.17.2.tar.gz) = 7c769293b4d79be2667993b8a88d42ac
-SHA256 (libprelude-0.9.17.2.tar.gz) = ba6caef5ba1df76a1c6989d71dbcd6f6cc373716e308f5d1b9389e47e302dfc9
-SIZE (libprelude-0.9.17.2.tar.gz) = 2031211
+MD5 (libprelude-0.9.20.2.tar.gz) = 4980065cc9fc7f8d6f0ca25e902b745d
+SHA256 (libprelude-0.9.20.2.tar.gz) = e6df8831fe9b8f12bd12cac92ac2a891b4dfaefedbb4e8c703a696272e188e06
+SIZE (libprelude-0.9.20.2.tar.gz) = 2407849
diff --git a/security/libprelude/files/patch-Makefile.in b/security/libprelude/files/patch-Makefile.in
index 76336a029818..ef5239dded2c 100644
--- a/security/libprelude/files/patch-Makefile.in
+++ b/security/libprelude/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2008-04-28 13:30:22.000000000 +0200
-+++ Makefile.in 2008-05-05 08:52:48.000000000 +0200
-@@ -1103,61 +1103,10 @@
+--- Makefile.in.orig 2008-09-09 04:55:27.000000000 -0400
++++ Makefile.in 2008-09-09 04:55:27.000000000 -0400
+@@ -1174,61 +1174,10 @@
$(INSTALL) -d -m 755 $(DESTDIR)$(PRELUDE_CONFIG_DIR);
$(INSTALL) -d -m 755 $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default;
$(INSTALL) -d -m 711 $(DESTDIR)$(PRELUDE_CONFIG_DIR)/profile;
diff --git a/security/libprelude/files/patch-bindings_perl_Prelude.c b/security/libprelude/files/patch-bindings_perl_Prelude.c
deleted file mode 100644
index 144066a2dccb..000000000000
--- a/security/libprelude/files/patch-bindings_perl_Prelude.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- bindings/perl/Prelude.c.orig Sat Dec 16 10:04:05 2006
-+++ bindings/perl/Prelude.c Thu Dec 21 11:02:42 2006
-@@ -15,6 +15,11 @@
- * declarations/attributes, and other compiler dependent labels.
- * ----------------------------------------------------------------------------- */
-
-+/* workaround to build with perl-5.005 */
-+#ifndef INT2PTR
-+# define INT2PTR(type, pointer) (type)(pointer)
-+#endif
-+
- /* template workaround for compilers that cannot correctly implement the C++ standard */
- #ifndef SWIGTEMPLATEDISAMBIGUATOR
- # if defined(__SUNPRO_CC)
diff --git a/security/libprelude/files/patch-libmissing_Makefile.in b/security/libprelude/files/patch-libmissing_Makefile.in
index ba58b13e6994..a3eb53616b12 100644
--- a/security/libprelude/files/patch-libmissing_Makefile.in
+++ b/security/libprelude/files/patch-libmissing_Makefile.in
@@ -1,25 +1,25 @@
---- libmissing/Makefile.in.orig Tue Feb 20 14:15:54 2007
-+++ libmissing/Makefile.in Thu Feb 22 15:27:37 2007
-@@ -447,7 +447,7 @@
- sys/time.h sys/time.h-t time.h time.h-t wchar.h wchar.h-t \
- wctype.h wctype.h-t
+--- libmissing/Makefile.in.orig 2008-09-09 04:55:25.000000000 -0400
++++ libmissing/Makefile.in 2008-09-09 04:55:25.000000000 -0400
+@@ -686,7 +686,7 @@
+ sys/time.h-t time.h time.h-t unistd.h unistd.h-t wchar.h \
+ wchar.h-t wctype.h wctype.h-t
MOSTLYCLEANDIRS = arpa netinet sys sys
-CLEANFILES = configmake.h configmake.h-t charset.alias ref-add.sed \
+CLEANFILES = configmake.h configmake.h-t ref-add.sed \
ref-del.sed
DISTCLEANFILES =
MAINTAINERCLEANFILES =
-@@ -465,8 +465,6 @@
- printf-args.c printf-parse.c vasnprintf.c vsnprintf.c
+@@ -709,8 +709,6 @@
+ vsnprintf.c
libmissing_la_LDFLAGS = $(AM_LDFLAGS)
LINK_WARNING_H = $(top_srcdir)/./link-warning.h
-charset_alias = $(DESTDIR)$(libdir)/charset.alias
-charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
all: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) all-am
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
-@@ -833,44 +831,6 @@
- } | sed '/""/d' > $@-t
+@@ -1247,44 +1245,6 @@
+ } > $@-t
mv $@-t $@
-# We need the following in order to install a simple file in $(libdir)
diff --git a/security/libprelude/pkg-plist b/security/libprelude/pkg-plist
index 1142e0282a40..e0ce5ece3632 100644
--- a/security/libprelude/pkg-plist
+++ b/security/libprelude/pkg-plist
@@ -21,6 +21,7 @@ include/libprelude/idmef-class.h
include/libprelude/idmef-criteria.h
include/libprelude/idmef-criterion-value.h
include/libprelude/idmef-data.h
+include/libprelude/idmef-message-helpers.h
include/libprelude/idmef-message-id.h
include/libprelude/idmef-message-print.h
include/libprelude/idmef-message-read.h
@@ -61,67 +62,22 @@ include/libprelude/prelude.h
include/libprelude/variable.h
lib/libprelude.la
lib/libprelude.so
-lib/libprelude.so.14
+lib/libprelude.so.17
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Prelude.pm
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/.packlist
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/Prelude.bs
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/Prelude.so
%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/PreludeEasy.pm
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy/.packlist
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy/PreludeEasy.bs
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy/PreludeEasy.so
+%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/_prelude.so
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/prelude-0.0.0-py%%PYTHON_VER%%.egg-info
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/prelude.py
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/prelude.pyc
share/aclocal/libprelude.m4
-%%PORTDOCS%%%%DOCSDIR%%/ch01.html
-%%PORTDOCS%%%%DOCSDIR%%/ch02.html
-%%PORTDOCS%%%%DOCSDIR%%/ch03.html
-%%PORTDOCS%%%%DOCSDIR%%/ch04.html
-%%PORTDOCS%%%%DOCSDIR%%/home.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/index.sgml
-%%PORTDOCS%%%%DOCSDIR%%/left.png
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-additional-data.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-criteria.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-criterion-value.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-data.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-message-print.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-message-read.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-message-write.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-path.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-time.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-tree-wrap.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-idmef-value.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-async.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-client-profile.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-client.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-connection-pool.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-connection.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-error.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-failover.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-hash.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-ident.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-inttypes.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-io.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-linked-object.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-list.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-log.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-msg.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-msgbuf.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-option-wide.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-option.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-plugin.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-string.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude-timer.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude-prelude.html
-%%PORTDOCS%%%%DOCSDIR%%/libprelude.devhelp
-%%PORTDOCS%%%%DOCSDIR%%/libprelude.devhelp2
-%%PORTDOCS%%%%DOCSDIR%%/pt01.html
-%%PORTDOCS%%%%DOCSDIR%%/pt02.html
-%%PORTDOCS%%%%DOCSDIR%%/pt03.html
-%%PORTDOCS%%%%DOCSDIR%%/pt04.html
-%%PORTDOCS%%%%DOCSDIR%%/right.png
-%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/up.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/libprelude
@dirrm etc/prelude/default
@dirrmtry etc/prelude/profile