aboutsummaryrefslogtreecommitdiff
path: root/security/libprelude
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-27 14:57:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-27 14:57:59 +0000
commit6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418 (patch)
tree95ab4f85bf7bf8cb530a6cecc47ac36a30dcab4b /security/libprelude
parent37e8aaec0258c9c628ea0ecb9fd1f26a00577d4b (diff)
downloadports-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.tar.gz
ports-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.zip
Notes
Diffstat (limited to 'security/libprelude')
-rw-r--r--security/libprelude/Makefile66
-rw-r--r--security/libprelude/distinfo4
-rw-r--r--security/libprelude/files/patch-src__include__prelude-plugin.h13
-rw-r--r--security/libprelude/pkg-descr16
-rw-r--r--security/libprelude/pkg-plist72
5 files changed, 91 insertions, 80 deletions
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index 832c42a56574..650f1a9ec5a7 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -2,75 +2,47 @@
# $FreeBSD$
PORTNAME= libprelude
-PORTVERSION= 1.0.1
-PORTREVISION= 9
+PORTVERSION= 1.2.6
CATEGORIES= security
-MASTER_SITES= http://www.prelude-ids.org/attachments/download/241/
+MASTER_SITES= http://www.prelude-siem.org/attachments/download/410/
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Framework library for Prelude NIDS
+COMMENT= Sensor support library from Prelude SIEM
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE.README
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
- libgmp.so:${PORTSDIR}/math/gmp \
libgnutls.so:${PORTSDIR}/security/gnutls \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt \
- libgpg-error.so:${PORTSDIR}/security/libgpg-error \
- libnettle.so:${PORTSDIR}/security/nettle \
- libp11-kit.so:${PORTSDIR}/security/p11-kit
-
-BROKEN_sparc64= does not compile
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
OPTIONS_DEFINE= DOCS PERL PYTHON
OPTIONS_SUB= yes
-USES= charsetfix gettext gmake iconv libtool pathfix pkgconfig
+USES= charsetfix gettext-runtime gmake iconv libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static \
- --localstatedir=/var \
- --enable-gtk-doc=no \
- --with-html-dir=${PREFIX}/share/doc
-
+CONFIGURE_ARGS= --without-lua \
+ --without-python3 \
+ --without-swig \
+ --without-valgrind \
+ ac_cv_path_RUBY=
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
ETCDIR= ${PREFIX}/etc/prelude
-PORTDOCS= *
-PERL_CONFIGURE_WITH= perl
+PERL_CONFIGURE_WITH= perl=${PERL}
PERL_USES= perl5
-PYTHON_CONFIGURE_WITH= python
-PYTHON_USES= python
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHON}
-PLIST_SUB+= PYTHON_VER="${PYTHON_VER}" VERSION="${PORTVERSION}"
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} '\,gnutls/extra\.h,d' \
- ${WRKSRC}/prelude-admin/prelude-admin.c \
- ${WRKSRC}/prelude-admin/server.c
+PYTHON_CONFIGURE_WITH= python2=${PYTHON_CMD}
+PYTHON_USES= python:2.7
+PYTHON_PLIST_SUB= VERSION="${PORTVERSION}"
post-install:
- ${INSTALL_MAN} ${WRKSRC}/docs/manpages/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-
.for f in client.conf global.conf idmef-client.conf tls.conf
- ${INSTALL_DATA} ${WRKSRC}/${f} \
+ ${MV} ${STAGEDIR}${ETCDIR}/default/${f} \
${STAGEDIR}${ETCDIR}/default/${f}.sample
- ${RM} ${STAGEDIR}${ETCDIR}/default/${f} # Remove files install-data-local installs
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${STAGEDIR}${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/libprelude/distinfo b/security/libprelude/distinfo
index 69e225563e8b..3e9bf168cdf9 100644
--- a/security/libprelude/distinfo
+++ b/security/libprelude/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libprelude-1.0.1.tar.gz) = 852d981e7d23e49ec25a96a7f54c19a7ee72cd786a0d02c43a27e3e770d5cb6b
-SIZE (libprelude-1.0.1.tar.gz) = 2791973
+SHA256 (libprelude-1.2.6.tar.gz) = 37541fc6c0593da09410d74b3801cdc672344bdfd711f689157fd41eac06c9c7
+SIZE (libprelude-1.2.6.tar.gz) = 2926210
diff --git a/security/libprelude/files/patch-src__include__prelude-plugin.h b/security/libprelude/files/patch-src__include__prelude-plugin.h
deleted file mode 100644
index be59c1f7ac4d..000000000000
--- a/security/libprelude/files/patch-src__include__prelude-plugin.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/include/prelude-plugin.h.orig 2012-06-02 00:12:30.000000000 +0900
-+++ src/include/prelude-plugin.h 2012-09-11 15:46:33.000000000 +0900
-@@ -61,9 +61,9 @@
- */
- #ifdef PRELUDE_APPLICATION_USE_LIBTOOL2
- # define lt_preloaded_symbols lt__PROGRAM__LTX_preloaded_symbols
--#endif
-
- extern const void *lt_preloaded_symbols[];
-+#endif
-
- #define PRELUDE_PLUGIN_SET_PRELOADED_SYMBOLS() \
- prelude_plugin_set_preloaded_symbols(lt_preloaded_symbols)
diff --git a/security/libprelude/pkg-descr b/security/libprelude/pkg-descr
index 5d58775683e6..dbaa74427df8 100644
--- a/security/libprelude/pkg-descr
+++ b/security/libprelude/pkg-descr
@@ -1,7 +1,13 @@
-Prelude is a new innovative hybrid Intrusion Detection system designed
-to be very modular, distributed, rock solid and fast.
+Prelude is a Universal "Security Information & Event Management" (SIEM)
+system. Prelude collects, normalizes, sorts, aggregates, correlates and
+reports all security-related events.
-This library provides a number of features to sensors, including
-communication with the manager.
+As well as being capable of recovering any type of log (system logs, syslog,
+flat files, etc.), Prelude benefits from a native support with a number of
+systems dedicated to enriching information even further (snort, samhain,
+ossec, auditd, etc.).
-WWW: http://www.prelude-ids.org/
+This library provides functionality for sensors (connection with a manager,
+handling sensor-exported options,...).
+
+WWW: https://www.prelude-siem.org/
diff --git a/security/libprelude/pkg-plist b/security/libprelude/pkg-plist
index efa2959ffd65..742ca4fbbfbf 100644
--- a/security/libprelude/pkg-plist
+++ b/security/libprelude/pkg-plist
@@ -11,6 +11,7 @@ include/libprelude/idmef.h
include/libprelude/idmef.hxx
include/libprelude/idmef-additional-data.h
include/libprelude/idmef-class.h
+include/libprelude/idmef-class.hxx
include/libprelude/idmef-criteria.h
include/libprelude/idmef-criteria.hxx
include/libprelude/idmef-criterion-value.h
@@ -20,6 +21,7 @@ include/libprelude/idmef-message-id.h
include/libprelude/idmef-message-print.h
include/libprelude/idmef-message-read.h
include/libprelude/idmef-message-write.h
+include/libprelude/idmef-object.h
include/libprelude/idmef-path.h
include/libprelude/idmef-path.hxx
include/libprelude/idmef-time.h
@@ -54,6 +56,7 @@ include/libprelude/prelude-linked-object.h
include/libprelude/prelude-list.h
include/libprelude/prelude-log.h
include/libprelude/prelude-log.hxx
+include/libprelude/prelude-macros.h
include/libprelude/prelude-message-id.h
include/libprelude/prelude-msg.h
include/libprelude/prelude-msgbuf.h
@@ -63,26 +66,69 @@ include/libprelude/prelude-plugin.h
include/libprelude/prelude-string.h
include/libprelude/prelude-thread.h
include/libprelude/prelude-timer.h
-lib/libprelude.a
lib/libprelude.so
-lib/libprelude.so.2
-lib/libprelude.so.2.19.1
-lib/libpreludecpp.a
+lib/libprelude.so.23
+lib/libprelude.so.23.1.0
lib/libpreludecpp.so
-lib/libpreludecpp.so.0
-lib/libpreludecpp.so.0.3.0
-man/man1/prelude-admin.1.gz
+lib/libpreludecpp.so.8
+lib/libpreludecpp.so.8.0.0
%%PERL%%%%SITE_ARCH%%/Prelude.pm
%%PERL%%%%SITE_ARCH%%/auto/Prelude/Prelude.so
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/PreludeEasy-%%VERSION%%-py%%PYTHON_VER%%.egg-info
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/PreludeEasy.py
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/PreludeEasy.pyc
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/_PreludeEasy.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_prelude.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/prelude-%%VERSION%%-py%%PYTHON_VER%%.egg-info
%%PYTHON%%%%PYTHON_SITELIBDIR%%/prelude.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/prelude.pyc
libdata/pkgconfig/libprelude.pc
+man/man1/prelude-admin.1.gz
share/aclocal/libprelude.m4
-@dir %%ETCDIR%%/profile
-@dir(root,wheel,711) /var/spool/prelude
+%%PORTDOCS%%share/gtk-doc/html/libprelude/api-index-full.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/deprecated-api-index.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/home.png
+%%PORTDOCS%%share/gtk-doc/html/libprelude/index.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/index.sgml
+%%PORTDOCS%%share/gtk-doc/html/libprelude/left.png
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-additional-data.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-criteria.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-criterion-value.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-data.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-message-print.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-message-read.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-message-write.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-path.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-time.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-tree-wrap.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-idmef-value.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-async.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-client-profile.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-client.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-connection-pool.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-connection.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-error.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-failover.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-hash.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-ident.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-inttypes.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-io.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-linked-object.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-list.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-log.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-msg.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-msgbuf.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-option-wide.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-option.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-plugin.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-string.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude-timer.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude-prelude.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude.devhelp
+%%PORTDOCS%%share/gtk-doc/html/libprelude/libprelude.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/libprelude/object-tree.html
+%%PORTDOCS%%share/gtk-doc/html/libprelude/right.png
+%%PORTDOCS%%share/gtk-doc/html/libprelude/style.css
+%%PORTDOCS%%share/gtk-doc/html/libprelude/up.png
+%%DATADIR%%/swig/libpreludecpp.i
+%%PERL%%%%DATADIR%%/swig/perl/libpreludecpp-perl.i
+%%PYTHON%%%%DATADIR%%/swig/python/libpreludecpp-python.i
+@dir(,,711) %%ETCDIR%%/profile
+@dir(,,711) /var/spool/prelude