aboutsummaryrefslogtreecommitdiff
path: root/security/libressl-devel
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-04-29 12:34:57 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-04-29 12:34:57 +0000
commit1963e088fb573bea082ca40314092af3ec691545 (patch)
tree941530ea05dfbdde3dc469ea2e9e0359f765cfc7 /security/libressl-devel
parent871b4dfc109260d465f0cb55d2d64e803f229a08 (diff)
downloadports-1963e088fb573bea082ca40314092af3ec691545.tar.gz
ports-1963e088fb573bea082ca40314092af3ec691545.zip
Notes
Diffstat (limited to 'security/libressl-devel')
-rw-r--r--security/libressl-devel/Makefile3
-rw-r--r--security/libressl-devel/files/patch-configure.ac19
2 files changed, 21 insertions, 1 deletions
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index 88c747488542..a39f6ac089a9 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libressl
PORTVERSION= 2.7.2
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
PKGNAMESUFFIX= -devel
@@ -27,7 +28,7 @@ CONFLICTS_INSTALL= libressl-[0-9]* \
NC_CONFIGURE_ENABLE= nc
GNU_CONFIGURE= yes
-USES= cpe libtool pathfix pkgconfig
+USES= autoreconf cpe libtool pathfix pkgconfig
USE_LDCONFIG= yes
OPTIONS_SUB= yes
CFLAGS+= -fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
diff --git a/security/libressl-devel/files/patch-configure.ac b/security/libressl-devel/files/patch-configure.ac
new file mode 100644
index 000000000000..dec843a3b125
--- /dev/null
+++ b/security/libressl-devel/files/patch-configure.ac
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2017-11-04 20:04:56 UTC
++++ configure.ac
+@@ -102,13 +102,13 @@ int main() {return 0;}
+
+ AC_ARG_ENABLE([asm],
+ AS_HELP_STRING([--disable-asm], [Disable assembly]))
+-AM_CONDITIONAL([OPENSSL_NO_ASM], [test "x$enable_asm" = "xno"])
++AM_CONDITIONAL([OPENSSL_NO_ASM],[test x$enableval = xno])
+
+ # Conditionally enable assembly by default
+ AM_CONDITIONAL([HOST_ASM_ELF_X86_64],
+- [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
++ [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64," -a x$enableval != xno])
+ AM_CONDITIONAL([HOST_ASM_MACOSX_X86_64],
+- [test "x$HOST_ABI" = "xmacosx" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
++ [test "x$HOST_ABI" = "xmacosx" -a "$host_cpu" = "x86_64," -a x$enableval != xno])
+
+ # Check if time_t is sized correctly
+ AC_CHECK_SIZEOF([time_t], [time.h])