aboutsummaryrefslogtreecommitdiff
path: root/security/libressl
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-04-24 19:50:42 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-04-24 19:50:42 +0000
commita9ccd9465bab9e8b999c4c4e94798af9ec9f5dae (patch)
tree9090e485f4dbb70f6001b6ce0c973768ad006af7 /security/libressl
parentb3316bb8028cb5734f164a8b05558d92b53a7bc6 (diff)
downloadports-a9ccd9465bab9e8b999c4c4e94798af9ec9f5dae.tar.gz
ports-a9ccd9465bab9e8b999c4c4e94798af9ec9f5dae.zip
security/libressl: Fix AES-NI assembly detection
- While here, fix broken man3 option Reported by: Franco Fichtner <franco opnsense org>
Notes
Notes: svn path=/head/; revision=468237
Diffstat (limited to 'security/libressl')
-rw-r--r--security/libressl/Makefile5
-rw-r--r--security/libressl/files/patch-configure.ac19
2 files changed, 21 insertions, 3 deletions
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 11c126b88ee7..7fb7965e6a70 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -3,7 +3,6 @@
PORTNAME= libressl
PORTVERSION= 2.6.4
-#DISTNAME= libressl-2.6.3
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
@@ -27,7 +26,7 @@ CONFLICTS_INSTALL= libressl-devel-[0-9]* \
NC_CONFIGURE_ENABLE= nc
GNU_CONFIGURE= yes
-USES= cpe libtool pathfix pkgconfig
+USES= autoreconf cpe libtool pathfix pkgconfig
USE_LDCONFIG= yes
OPTIONS_SUB= yes
CFLAGS+= -fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
@@ -36,7 +35,7 @@ INSTALL_TARGET= install-strip
TEST_TARGET= check
post-patch-MAN3-off:
- ${REINPLACE_CMD} -e 's/^install-man: install-man3/install-man:/' \
+ ${REINPLACE_CMD} -e '/^install-man:/s/install-man3//' \
-e '/$$(MAKE) $$(AM_MAKEFLAGS) install-data-hook/d' \
${WRKSRC}/man/Makefile.in
diff --git a/security/libressl/files/patch-configure.ac b/security/libressl/files/patch-configure.ac
new file mode 100644
index 000000000000..dec843a3b125
--- /dev/null
+++ b/security/libressl/files/patch-configure.ac
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2017-11-04 20:04:56 UTC
++++ configure.ac
+@@ -102,13 +102,13 @@ int main() {return 0;}
+
+ AC_ARG_ENABLE([asm],
+ AS_HELP_STRING([--disable-asm], [Disable assembly]))
+-AM_CONDITIONAL([OPENSSL_NO_ASM], [test "x$enable_asm" = "xno"])
++AM_CONDITIONAL([OPENSSL_NO_ASM],[test x$enableval = xno])
+
+ # Conditionally enable assembly by default
+ AM_CONDITIONAL([HOST_ASM_ELF_X86_64],
+- [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
++ [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64," -a x$enableval != xno])
+ AM_CONDITIONAL([HOST_ASM_MACOSX_X86_64],
+- [test "x$HOST_ABI" = "xmacosx" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
++ [test "x$HOST_ABI" = "xmacosx" -a "$host_cpu" = "x86_64," -a x$enableval != xno])
+
+ # Check if time_t is sized correctly
+ AC_CHECK_SIZEOF([time_t], [time.h])