aboutsummaryrefslogtreecommitdiff
path: root/security/libressl
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-03-04 09:34:25 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-03-04 09:34:25 +0000
commitf9f916b0101368ac1f63e5e08d650e62de74c084 (patch)
treeaba66a8dd270902845b91862c52d8cce5e8f0e40 /security/libressl
parent22832b2f3b16f7c722d029f1b02c46f8603ae64b (diff)
downloadports-f9f916b0101368ac1f63e5e08d650e62de74c084.tar.gz
ports-f9f916b0101368ac1f63e5e08d650e62de74c084.zip
Notes
Diffstat (limited to 'security/libressl')
-rw-r--r--security/libressl/Makefile5
-rw-r--r--security/libressl/distinfo4
-rw-r--r--security/libressl/files/patch-include-openssl-opensslv.h8
-rw-r--r--security/libressl/pkg-plist12
4 files changed, 15 insertions, 14 deletions
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 1d67146af518..0a78bfb0b254 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libressl
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_OPENBSD}
MASTER_SITE_SUBDIR= LibreSSL
@@ -11,11 +11,12 @@ MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Free version of the SSL/TLS protocol forked from OpenSSL
LICENSE= BSD4CLAUSE
+CPE_VENDOR= openbsd
CONFLICTS?= openssl-*
GNU_CONFIGURE= yes
-USES= libtool pkgconfig pathfix
+USES= libtool pkgconfig pathfix cpe
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/security/libressl/distinfo b/security/libressl/distinfo
index f263baa9cc4b..0782e507abba 100644
--- a/security/libressl/distinfo
+++ b/security/libressl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libressl-2.1.3.tar.gz) = eb2f370971408fb10af6453e556465c8eee728ac333bf1eb47ec1a5112304f7c
-SIZE (libressl-2.1.3.tar.gz) = 2847182
+SHA256 (libressl-2.1.4.tar.gz) = e8e08535928774119a979412ee8e307444b7a1a42c8c47ac06ee09423ca9a04e
+SIZE (libressl-2.1.4.tar.gz) = 2865654
diff --git a/security/libressl/files/patch-include-openssl-opensslv.h b/security/libressl/files/patch-include-openssl-opensslv.h
index c51dfea65057..7a163d68ff3e 100644
--- a/security/libressl/files/patch-include-openssl-opensslv.h
+++ b/security/libressl/files/patch-include-openssl-opensslv.h
@@ -1,11 +1,11 @@
---- include/openssl/opensslv.h.orig 2014-12-14 23:08:55 UTC
-+++ include/openssl/opensslv.h
+--- include/openssl/opensslv.h.orig 2015-02-14 20:11:02.000000000 +0100
++++ include/openssl/opensslv.h 2015-03-04 08:47:30.514145411 +0100
@@ -3,7 +3,7 @@
#define HEADER_OPENSSLV_H
#define LIBRESSL_VERSION_NUMBER 0x20000000L
-#define OPENSSL_VERSION_NUMBER 0x20000000L
-+#define OPENSSL_VERSION_NUMBER 0x1000107fL
- #define OPENSSL_VERSION_TEXT "LibreSSL 2.1.3"
++#define OPENSSL_VERSION_NUMBER 0x1000107fL
+ #define OPENSSL_VERSION_TEXT "LibreSSL 2.1.4"
#define OPENSSL_VERSION_PTEXT " part of " OPENSSL_VERSION_TEXT
diff --git a/security/libressl/pkg-plist b/security/libressl/pkg-plist
index ad24f1dcb16b..cdc49c07d1ad 100644
--- a/security/libressl/pkg-plist
+++ b/security/libressl/pkg-plist
@@ -52,7 +52,6 @@ include/openssl/poly1305.h
include/openssl/rand.h
include/openssl/rc2.h
include/openssl/rc4.h
-include/openssl/rc5.h
include/openssl/ripemd.h
include/openssl/rsa.h
include/openssl/safestack.h
@@ -74,12 +73,12 @@ include/openssl/x509_vfy.h
include/openssl/x509v3.h
lib/libcrypto.a
lib/libcrypto.so
-lib/libcrypto.so.30
-lib/libcrypto.so.30.0.3
+lib/libcrypto.so.32
+lib/libcrypto.so.32.0.0
lib/libssl.a
lib/libssl.so
-lib/libssl.so.30
-lib/libssl.so.30.0.0
+lib/libssl.so.32
+lib/libssl.so.32.0.0
libdata/pkgconfig/libcrypto.pc
libdata/pkgconfig/libssl.pc
libdata/pkgconfig/openssl.pc
@@ -1042,6 +1041,7 @@ man/man3/SSL_CTX_use_RSAPrivateKey_file.3.gz
man/man3/SSL_CTX_use_certificate.3.gz
man/man3/SSL_CTX_use_certificate_ASN1.3.gz
man/man3/SSL_CTX_use_certificate_chain_file.3.gz
+man/man3/SSL_CTX_use_certificate_chain_mem.3.gz
man/man3/SSL_CTX_use_certificate_file.3.gz
man/man3/SSL_CTX_use_psk_identity_hint.3.gz
man/man3/SSL_SESSION_free.3.gz
@@ -1382,4 +1382,4 @@ man/man3/ssl.3.gz
man/man3/ui.3.gz
man/man3/ui_compat.3.gz
man/man3/x509.3.gz
-@dirrmtry include/openssl
+@dir include/openssl