aboutsummaryrefslogtreecommitdiff
path: root/security/libressl
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-05-03 08:44:36 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-05-03 08:44:36 +0000
commit1fba56590ed36e7f70834c421a57531676025c62 (patch)
treef77abf723065a421f21f67baff80dd5a4532d34a /security/libressl
parent445c7ccb3889d87cefb459bb38a0055c11809205 (diff)
downloadports-1fba56590ed36e7f70834c421a57531676025c62.tar.gz
ports-1fba56590ed36e7f70834c421a57531676025c62.zip
Notes
Diffstat (limited to 'security/libressl')
-rw-r--r--security/libressl/Makefile3
-rw-r--r--security/libressl/distinfo6
-rw-r--r--security/libressl/files/patch-CVE-2017-830132
3 files changed, 4 insertions, 37 deletions
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 60a96c616dfa..800a893d1815 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libressl
-PORTVERSION= 2.5.3
-PORTREVISION= 1
+PORTVERSION= 2.5.4
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
diff --git a/security/libressl/distinfo b/security/libressl/distinfo
index edd3389c2cb6..5d9aaa6bab77 100644
--- a/security/libressl/distinfo
+++ b/security/libressl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491933706
-SHA256 (libressl-2.5.3.tar.gz) = 14e34cc586ec4ce5763f76046dcf366c45104b2cc71d77b63be5505608e68a30
-SIZE (libressl-2.5.3.tar.gz) = 3285151
+TIMESTAMP = 1493799912
+SHA256 (libressl-2.5.4.tar.gz) = 107a5b522fbb8318d4c3be668075e5e607296f0a9255d71674caa94571336efa
+SIZE (libressl-2.5.4.tar.gz) = 3286042
diff --git a/security/libressl/files/patch-CVE-2017-8301 b/security/libressl/files/patch-CVE-2017-8301
deleted file mode 100644
index 21b24aa330e2..000000000000
--- a/security/libressl/files/patch-CVE-2017-8301
+++ /dev/null
@@ -1,32 +0,0 @@
-https://marc.info/?l=openbsd-cvs&m=149342064612660
-
-===================================================================
-RCS file: /cvs/src/lib/libcrypto/x509/x509_vfy.c,v
-retrieving revision 1.61
-retrieving revision 1.61.4.1
-diff -u -r1.61 -r1.61.4.1
---- crypto/x509/x509_vfy.c 2017/02/05 02:33:21 1.61
-+++ crypto/x509/x509_vfy.c 2017/04/28 23:12:04 1.61.4.1
-@@ -1,4 +1,4 @@
--/* $OpenBSD: x509_vfy.c,v 1.61 2017/02/05 02:33:21 beck Exp $ */
-+/* $OpenBSD: x509_vfy.c,v 1.61.4.1 2017/04/28 23:12:04 beck Exp $ */
- /* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
- * All rights reserved.
- *
-@@ -541,15 +541,7 @@
- /* Safety net, error returns must set ctx->error */
- if (ok <= 0 && ctx->error == X509_V_OK)
- ctx->error = X509_V_ERR_UNSPECIFIED;
--
-- /*
-- * Safety net, if user provided verify callback indicates sucess
-- * make sure they have set error to X509_V_OK
-- */
-- if (ctx->verify_cb != null_callback && ok == 1)
-- ctx->error = X509_V_OK;
--
-- return(ctx->error == X509_V_OK);
-+ return ok;
- }
-
- /* Given a STACK_OF(X509) find the issuer of cert (if any)